The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BoxTrapper does not work

Discussion in 'General Discussion' started by PbG, Apr 20, 2004.

  1. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    I activated, installed and started testing the Features in Cpanel Pro on one of our (FreeBSD) boxes. Thus far I have tested:

    Leech Protection throws an error (bug acknowledged/reported) and definately should not be set to less than 75. I personally recommend 100. In it's current design it can only be considered a braking mechanism to prevent rampant theft of services. It is not sophisticated enough to discern between valid users accessing the protected area from a proxy eg: AOL users and counts each instance of their IP while in the same class and subnet against them. This is problematic since each time the AOL surfer requests a new page they generate a slightly different IP. Thus they will end up getting blocked in a matter of minutes if this is set too low. Additionally there is a problem with the redirect in this feature as well. It returns a 302 error.

    BoxTrapper Returns an error (local delivery failed) to the sender when enabled instead of a request for email verification.

    Submit Support Request (worked without incident)

    I will try the gallery maker next. If anyone else has tested these features please share your experience and the OS used . . .
     
  2. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Which OS/version are you referring to??

     
  3. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Hmmn thats interesting Cpanel told me they were able to duplicate the errors. Perhaps they were testing on a FreeBSD box as well.
     
  4. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    You are using it with an eMail address that has been setup, correct?

    It will not work with any catch-all addresses.
     
  5. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
  6. Ganga

    Ganga Well-Known Member

    Joined:
    Oct 2, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    I'm having the same problem and I am testing it on a mail that has been set up ad hoc, not a catch all.
     
  7. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    Re: Re: BoxTrapper does not work

    Ganga what OS are you running?

     
  8. Ganga

    Ganga Well-Known Member

    Joined:
    Oct 2, 2003
    Messages:
    105
    Likes Received:
    0
    Trophy Points:
    16
    RH 9.0.

    Strange enough, upgrading cPanel to the latest current release fixed it.

    When the automatic /scripts/upcp run from cronjob (as I forgot to deactivate it) cPanel downgraded to the latest stable release, however Boxtrapper still works!!!

    Odd, isn't it?
     
  9. PbG

    PbG Well-Known Member

    Joined:
    Mar 11, 2003
    Messages:
    241
    Likes Received:
    0
    Trophy Points:
    16
    That sounds right I got an email from bugzilla that they also fixed the Leech Protection. Makes sense it would be working it's way thru the releases.

     
  10. big

    big Well-Known Member

    Joined:
    Aug 12, 2001
    Messages:
    224
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Earth
    i tried to install it on freebsd 4.9 freebsd 5.2 and redhat 3.0 EL all segfaults:
    2004-06-01 01:46:20 1BUvXv-0007yU-1m ** test@kuwaitnet.net R=virtual_boxtraper_user T=virtual_boxtrapper_userdelivery: Child process of virtual_boxtrapper_userdelivery transport (running command "/usr/local/cpanel/bin/boxtrapper "${local_part}@${domain}"") was terminated by signal 11 (Segmentation fault)

    its setup for virtual email.

    any idea why it segfault ?
     
Loading...

Share This Page