Branding Editor Issues / Not Saving Changes

griffinjt

Registered
Nov 4, 2010
4
0
51
Hi,

First of all I just want to say that cPanel is absolutely awesome. It is so much better than stupid Plesk!

I am trying to brand my cPanel theme, but the cPanel branding is not saving any changes or is not saving all changes. I log in to WHM as the root, go to cPanel, then Branding, etc. etc. When I go to edit a theme (this is for x3), for one I cannot edit the stylesheet. But before that, this is in my stylesheet when it first loads:

/unprotected/broken.css

Is this supposed to be here? I don't think it is, so I don't know if it relays that there is an issue or not. Whether it is there or not does not effect the outcome. Here is the error I get when trying to save the stylesheet:

Code:
open  failed: No such file or directory at cpanel line 4774
	Carp::croak('open  failed: No such file or directory') called at /usr/local/cpanel/Cpanel/Fileman.pm line 1152
	Cpanel::Fileman::fmsavefile('/var/cpanel/userhomes/cpanel/cpanelbranding/x3/Thomas Griffin Me...', '', 'body { background: #484848; }') called at cpanel line 4774
	main::__ANON__('/var/cpanel/userhomes/cpanel/cpanelbranding/x3/Thomas Griffin Me...', '', 'body { background: #484848; }') called at cpanel line 1335
	eval {...} called at cpanel line 1335
	main::real_exectag('<cpanel Fileman="fmsavefile($FORM{\'dir\'},$FORM{\'file\'},$FORM...') called at cpanel line 3876
	main::dotag_finished_headers(0) called at cpanel line 3704
	main::cpanel_parseblock('<cpanel Branding="tempsetbrandingpkg($FORM{\'brandingpkg\'})">^J<...') called at cpanel line 3612
	main::cpanel_parse('GLOB(0xfe70a00)') called at cpanel line 5121
	main::run_standard_mode() called at cpanel line 424
Help here would be appreciated.

Also, when I go to change the Header/Footer images, when I replace the header, I simply get a blank screen. Replacing the logo works fine, but replacing the header does not work, even though it shows the image as uploaded and in place on the screen.

Any help here is greatly appreciated!

Thomas
 

cPanelTristan

Quality Assurance Analyst
Staff member
Oct 2, 2010
7,607
42
348
somewhere over the rainbow
cPanel Access Level
Root Administrator
Hello Thomas,

We have case internal case #46915 about this issue. It occurs when the custom branding package does not have any file named local.css in it. You could try to create a file local.css in the branding package to see if this would temporarily resolve the issue in the meantime until the case has been pushed into production, since it currently hasn't been released to the existing production tiers.

If this does not resolve the issue, please open up a ticket to WHM > Support Center > Contact cPanel or using the link in my signature so we can attach this to the existing case and get a status update on how to correct it for existing customers.

Thanks.