The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Broke after urgent update?!

Discussion in 'General Discussion' started by youdrovemetoit, Mar 12, 2004.

  1. youdrovemetoit

    Joined:
    Feb 12, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I just logged into WHM and it told me i had to upgrade because there was a security hole in the resetting of passwords or something. So i clicked update and wated 10 mins. It sais it could not locate a file on cpanels upate server and then said => Installing and hung for ages at 30%. So i figured it had crashed and tried to do it again. This thime it completed and reached 100% but then i tired to carry out other tasks and all of them returned 404. CPanel and WHM are now broke, if i try to access any ports 2086 2082 etc it just returns a 404.

    Any ideas on how to fix or what went wrong?
     
  2. youdrovemetoit

    Joined:
    Feb 12, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    I cant even access ssh to fix manually
     
  3. tAzMaNiAc

    tAzMaNiAc Well-Known Member

    Joined:
    Feb 16, 2003
    Messages:
    559
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Sachse, TX
    This ain't the website to request urgent help! Help will come via this website, but not as fast as you would like.

    Call cPanel or do a support ticket request and they'll do it if emergency like yours.

    Sorry, and good luck.
     
  4. pauldorn

    pauldorn Registered

    Joined:
    Sep 5, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    URGENT UPDATE FAILURE

    I also have similar failure. This is causing a HIGH volume of support calls as users cannot access their cpanel. Please advise ASAP
     
  5. askthexperts

    askthexperts Registered

    Joined:
    Mar 12, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Same Issue Here

    Did an attempted update, hung, so restarted the update and lost my server.

    Someone (a mod/admin?) should sticky this right away.
     
  6. navmonkey

    navmonkey Well-Known Member

    Joined:
    Aug 19, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    So should I go ahead for the upgrade as suggested by cPanel?

    Has the been problem fixed? Please adivce.

    Is this an isolated incident?
     
  7. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    and what about the 30 other threads (most with more information than this one) dealing with this issue?

    I had already disabled the email password updates. I am waiting a couple of days to evaluate the fallout from this incident before updating. When I checked the changelog earlier today there had already been 4 STABLE updates. You call that stable?
     
  8. navmonkey

    navmonkey Well-Known Member

    Joined:
    Aug 19, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Any idea what exactly is the security hole the reset password function introduce?
     
  9. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
     
  10. BOL

    BOL Member

    Joined:
    Apr 10, 2003
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    Still broke. Don't update yet.
     
  11. navmonkey

    navmonkey Well-Known Member

    Joined:
    Aug 19, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    I have disabled "Allow cPanel users to reset their password via email " under "Tweak Settings" in WHM before an update become available.

    Hope this help to "patch" the hole for the time being.
     
  12. SarcNBit

    SarcNBit Well-Known Member

    Joined:
    Oct 14, 2003
    Messages:
    1,010
    Likes Received:
    3
    Trophy Points:
    38
    I just saw in another thread that you will need to

    chmod 0 /scripts/upcp

    if you do not want your server to update automatically at 3PM EST regardless of your server settings.
     
  13. navmonkey

    navmonkey Well-Known Member

    Joined:
    Aug 19, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for the hint. I issued the command to make sure upcp will not automatically executed at its own will until the upgrade (bug fix patch) issue has cleared up a bit.

    Have you tried to upgrade your server to 9.1.0 build 49 or later?
     
  14. nickn

    nickn Well-Known Member
    PartnerNOC

    Joined:
    Jun 15, 2003
    Messages:
    619
    Likes Received:
    1
    Trophy Points:
    18
    Yep, all our machines upgraded with 0 issues whatsoever. :)
     
  15. PWSowner

    PWSowner Well-Known Member

    Joined:
    Nov 10, 2001
    Messages:
    2,948
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    ON, Canada
    I upgraded to 9.1 R72 earlier with no problem.
     
  16. navmonkey

    navmonkey Well-Known Member

    Joined:
    Aug 19, 2003
    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    6
    Just upgraded to cPanel 9.1.0-S73 without any problem. :)
     
Loading...

Share This Page