broken apache!!! 10 hours my apache is down!! help!!!

the_bobara

Well-Known Member
PartnerNOC
Sep 23, 2004
92
0
156
Bulgaria
cPanel Access Level
Root Administrator
yesterday one of cPanel support guys login into my server to rebuild apache cos it doesn`t seem to install GD and MM modules after rebuild everything messed up. everything!!!!!!
now 10 hours i don`t have apache!!!!
i tried milion variants and nothing!!!
the looser from cPanel that broke my apache don`t reply to me.
now 10 hours i`m trying to fix the apache but with milion variants of recompiling and patching httpd.conf it don`t work!

please i`m ready to pay for the fix but i want it in minutes!


please tell me what yo do.
 

the_bobara

Well-Known Member
PartnerNOC
Sep 23, 2004
92
0
156
Bulgaria
cPanel Access Level
Root Administrator
now i have my apache working, but all mysql data is still showing as ?? (question marks)
my my.cnf is:
[mysqld]
datadir=/home/mysqld/
set-variable = max_connections=500
set-variable = max_user_connections=30
safe-show-database
default-character-set = cp1251
default-collation= cp1251_bulgarian_ci
old-passwords
socket=/var/tmp/mysql.sock
init-connect=SET NAMES cp1251

[mysqldump]
quick
max_allowed_packet = 16M

[mysql]
no-auto-rehash

[mysqlhotcopy]
interactive-timeout

[client]
default-character-set = cp1251
--------------------
all sql files are with right encoding. I even dowloaded one of them - it is fine.
but when they are showing in my sites they are ???????? questionmarks

i tried to recompile apache without success.


please help. i realy need to fix this as soon as posible
 

sh4ka

Well-Known Member
May 12, 2005
444
0
166
Uruguay
cPanel Access Level
DataCenter Provider
Try /scripts/fixmysql or reinstalling mysql from the script /scripts/mysqlup --force, that would be a fast solution as far as I can see.. And of course, don't forget to contact your Datacenter, they must help you if they broke it.

Good luck!
 

the_bobara

Well-Known Member
PartnerNOC
Sep 23, 2004
92
0
156
Bulgaria
cPanel Access Level
Root Administrator
it is not the data center. cPanel support broke it!!! and now don`t want to tell me how to fix it, even don`t know to tell me what the tech did. i don`t know what exactly the tech did and now i don`t have working with cyrilic chars mysql...because of cPanel techs!!!

they even don`t respond...
 

casey

Well-Known Member
Jan 17, 2003
2,291
0
191
Try changing init-connect to
init-connect=SET NAMES binary

Then restart mysql. That should display the characters properly.