The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug? Add forwarder dialog accepting Uppercase Emailadress (green checkmark)

Discussion in 'E-mail Discussions' started by lorio, Apr 15, 2015.

  1. lorio

    lorio Well-Known Member

    Joined:
    Feb 25, 2004
    Messages:
    243
    Likes Received:
    3
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    When adding forwarders via the Cpanel Webmail screen (Port 2096) the emailadress can be entered with uppercase characters and a green checkmark is displayed.

    When trying to submit the form the creation of the forwarder the following error message is displayed:
    Code:
    -- Add a New Forwarder
    
    All email that is sent to “” will forward to “”
    (Warning: “Uppercase@Domain.TLD” does not refer to a valid local email account or alias. The system will not create a forwarder, because it already sends that email to the default address.) 
    When adding the email in lowercase the forwarder is created.

    Perhaps the dialog can be changed to just convert uppercase to lowercase. The green mark is misleading. IMHO lowercase was always the way to go to prevent ugly things in the backend ;-)

    Not sure what to put into the bugreport. Allow uppercase, just convert to lowercase or remove green checkmark when uppercase characters are in the field.

    Thanks.
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm unclear on what you're doing here exactly to try and duplicate. When you login to /webmail (or, server.domain.com:2096) are you logging in as the cPanel user or with an email account?

    What tier of cPanel are you on? Also, are you using Paper Lantern?

    When I login to Webmail using an email account, prior to clicking thru to Horde, or Roundcube, at top of page where my full email is displayed, I select "Forwarders" from the menu, I get an option to add the forward's destination only.

    When I login as cPanel user to cPanel, then go to Forwarders, select, Add Forwarder I get an option to add the email username, and select the domain of course. I can add the email username in all caps if I like, I can add the forward destination in all caps as well. On saving, "Add Forwarder" it does save, and the email username is displayed (in saved result message) as the full email address, lower case. Destination is displayed here as upper case as I typed it.

    I don't see a green check mark anywhere here. I am using Paper Lantern.
     
  3. lorio

    lorio Well-Known Member

    Joined:
    Feb 25, 2004
    Messages:
    243
    Likes Received:
    3
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Thanks for your post.

    The green check mark is only on x3 Themes. Paper Lantern shows nothing.
    When using Paper Lantern the uppercase email is accepted and no error message is shown.
    But the forwarder is not created. This is all done via the webmail account of a email user.

    Installed Version: 11.48.3.0
    Current Tier: stable

    This behaviour was also reproducable under lower versions. I was asked by a user about this problem. I think most users are just used to enter emails in lower case.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,448
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    You logged into /webmail as an email user, (on x3) and there, clicked "Forwarding Options" to get to the Forwarders page. From here you clicked, Add Forwarder. And then what?
     
  5. lorio

    lorio Well-Known Member

    Joined:
    Feb 25, 2004
    Messages:
    243
    Likes Received:
    3
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    In a nutshell. Emailadresses can be entered with uppercase characters. Error message in x3, no error in paper lantern. But it isn't possible to add these emailadress as forwarders. Everything has to be lowercase.
    In x3 you get the error message as quotes in my first post, paper lantern presents an empty screen where you can click to go back.

    I had some users which complained about that. Since they get warning as long as the email is not complete or correct I can understand that some user are irritated.
    So please change the check routines during entering the emailadress to complain about uppercase characters.
    Or just convert all entered characters to lowercase.

    I am not looking for instructions how to add a forwarder. I am looking for a consistent behaviour of the GUI.
    Thanks for your time and pushing me to check paper lantern again.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    651
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a bug report using the link below?

    Submit A Bug Report

    You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page