The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug: Envelope-to: headder in mail is incorrect when spamassassin is in use

Discussion in 'E-mail Discussions' started by loafer, Sep 17, 2005.

  1. loafer

    loafer Member

    Joined:
    May 13, 2003
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
  2. claven177

    claven177 Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Taipei
    It is strange.
    when spamassassin is in use, the e-mail Envelope-to will be modify as real mail box addreess
    it donot show alias e-mail address


    ex.
    If test1@name.com forward to test2@name.com
    when spamassassin OFF --> Envelope-to show test1@name.com
    when spamassassin ON --> Envelope-to show test2@name.com
     
  3. claven177

    claven177 Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Taipei
    when spamassassin OFF

    Return-path: <hap454@seed.net.tw>
    Envelope-to: test1@name.com
    Delivery-date: Tue, 22 Nov 2005 17:44:22 +0800
    Received: from [168.95.4.119] (helo=msr19.hinet.net)
    by p4.wewehost.us with esmtp (Exim 4.52)
    id 1EeUhK-0006cj-7w
    for test1@name.com; Tue, 22 Nov 2005 17:44:22 +0800
    Received: from mmm30f16e72125 (210-35-15-17.HINET-IP.hinet.net [210.35.15.77])
    by msr19.hinet.net (8.9.3/8.9.3) with SMTP id RAA10980
    for <test1@name.com>; Tue, 22 Nov 2005 17:44:19 +0800 (CST)
    From: hap454@seed.net.tw
    Message-ID: <010c01c5ef49$4d15e9e0$7000a8c0@mmm30f16e72125>
    To: <test1@name.com>
    Subject: Re: test4
    Date: Tue, 22 Nov 2005 17:44:13 +0800
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_NextPart_000_0109_01C5EF8C.5A2F5B00"
    X-Priority: 3
    X-MSMail-Priority: Normal
    X-Mailer: Microsoft Outlook Express 6.00.2900.2180
    Disposition-Notification-To: <hap454@seed.net.tw>
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180





    when spamassassin ON
    Return-path: <hap454@seed.net.tw>
    Envelope-to: test2@name.com
    Delivery-date: Tue, 22 Nov 2005 17:43:20 +0800
    Received: from zdna by p4.wewehost.us with local-bsmtp (Exim 4.52)
    id 1EeUgJ-0006Va-Ex
    for test2@name.com; Tue, 22 Nov 2005 17:43:20 +0800
    X-Spam-Checker-Version: SpamAssassin 3.1.0 (2005-09-13) on p4.wewehost.us
    X-Spam-Level:
    X-Spam-Status: No, score=0.7 required=5.0 tests=AWL,HTML_MESSAGE,NO_REAL_NAME
    autolearn=no version=3.1.0
    Received: from [168.95.4.114] (helo=msr14.hinet.net)
    by p4.wewehost.us with esmtp (Exim 4.52)
    id 1EeUgI-0006VQ-Vw
    for test1@name.com; Tue, 22 Nov 2005 17:43:19 +0800
    Received: from mmm30f16e72125 (210-35-15-17.HINET-IP.hinet.net [210.35.15.77])
    by msr14.hinet.net (8.9.3/8.9.3) with SMTP id RAA08892
    for <test1@name.com>; Tue, 22 Nov 2005 17:43:16 +0800 (CST)
    From: hap454@seed.net.tw
    Message-ID: <00fb01c5ef49$273ae770$7000a8c0@mmm30f16e72125>
    To: <test1@name.com>
    Subject: Re: test4
    Date: Tue, 22 Nov 2005 17:43:10 +0800
    MIME-Version: 1.0
    Content-Type: multipart/alternative;
    boundary="----=_NextPart_000_00F8_01C5EF8C.345EDFE0"
    X-Priority: 3
    X-MSMail-Priority: Normal
    X-Mailer: Microsoft Outlook Express 6.00.2900.2180
    Disposition-Notification-To: <hap454@seed.net.tw>
    X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
     
  4. claven177

    claven177 Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Taipei
  5. Rooter

    Rooter Well-Known Member

    Joined:
    Apr 23, 2003
    Messages:
    146
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Houston, Texas, U.S.A.
    cPanel Access Level:
    Root Administrator
    This may or may not be a solution to the problem, but I would try it anyway.

    1) Login to WHM.

    2) Click on "Exim Configuration Editor"

    3) Uncheck/disable/clear box for "Always set the Sender: header when the sender is changed from the actual sender."

    4) Click "Save".

    5) Test Email.
     
  6. claven177

    claven177 Well-Known Member

    Joined:
    Sep 3, 2003
    Messages:
    61
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Taipei
    Thanks.

    I always

    Uncheck/disable/clear box for "Always set the Sender: header when the sender is changed from the actual sender."


    but no use.
     
Loading...

Share This Page