The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

BUG: Exim on Another Port (26)

Discussion in 'General Discussion' started by EcpHosting, Jun 4, 2003.

  1. EcpHosting

    EcpHosting Well-Known Member

    Joined:
    Dec 16, 2002
    Messages:
    69
    Likes Received:
    0
    Trophy Points:
    6

    I hate to sound repetitive with postings (as there are quite a few of these similiar topics already).

    The Problem: It seems each time CPanel updates or the server restarts, "exim on another port" under the "service manager" option in CPanel, fails to work.

    The Ghetto Solution: Change the port to another port and change back to the original port number or possibly uncheck the option for another port and check back. This must be done EVERY TIME the server reboots or CPanel is upgraded (as the folks at Cpanel with all of their infinite wisdom has yet to resolve this).

    A newly Discovered Solution: Track down /etc/chkserv.d/exim-26 (replace 26 with whatever port number your alternate port is set to) and remove all the spaces before the line of command (as mentioned here: http://forums.cpanel.net/showthread.php?s=&threadid=9170)

    The NEW Problem: Now, no matter what happens, the alternate port setting no longer works. Could it be a problem with chkserv? Perhaps a new CPanel build? No telling. Anyone have any ideas?







    cPanel.net Support Ticket Number:
     
  2. ElrondBCN

    ElrondBCN Active Member

    Joined:
    May 19, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Boston, MA USA
    Yea, I am also having this problem. I've been using your ghetto solution so far :)

    cPanel.net Support Ticket Number:
     
  3. ElrondBCN

    ElrondBCN Active Member

    Joined:
    May 19, 2003
    Messages:
    35
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Boston, MA USA
    One way that I've been getting it to work is to run /usr/sbin/exim -oX 26 -bd from the command line after a restart. That seems to get it working on both specified ports now.

    cPanel.net Support Ticket Number:
     
Loading...

Share This Page