The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug in Mailman version 2.0.11

Discussion in 'E-mail Discussions' started by davidmx, Sep 11, 2002.

  1. davidmx

    davidmx Registered

    Joined:
    Sep 11, 2002
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Mailmain was working fine before my update to version 5.0. Now, when I try to enter every list on my server I get this message:

    ----------------------------------------
    Bug in Mailman version 2.0.11

    We're sorry, we hit a bug!
    Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.
    ----------------------------------------

    I tried with /scrtipts/fixoldlistswithsuexec and /scripts/fixmailmanwithsuexec but the problem was not fixed.

    Some suggestion??

    Thanks.


    When I sent mail to the list, the message is not delivered and I get back this mail:

    This message was created automatically by mail delivery software (Exim).

    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:

    pipe to |/usr/local/cpanel/3rdparty/mailman/mail/wrapper post info_domain.com
    generated by info@domain.com
    Child process of virtual_address_pipe transport returned 1 from command:
    /usr/local/cpanel/3rdparty/mailman/mail/wrapper

    The following text was generated during the delivery attempt:

    ------ pipe to |/usr/local/cpanel/3rdparty/mailman/mail/wrapper post info_domain.com
    generated by info@domain.com ------

    Traceback (innermost last):
    File &/usr/local/cpanel/3rdparty/mailman/scripts/post&, line 94, in ?
    main()
    File &/usr/local/cpanel/3rdparty/mailman/scripts/post&, line 73, in main
    mlist = MailList.MailList(listname, lock=0)
    File &/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py&, line 79, in __init__
    self.Load()
    File &/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py&, line 892, in Load
    dict, e = self.__load(dbfile)
    File &/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py&, line 869, in __load
    fp = open(dbfile)
    IOError: [Errno 13] Permission denied: '/usr/local/cpanel/3rdparty/mailman/lists/info_domain.com/config.db'
     
  2. Juanra

    Juanra Well-Known Member

    Joined:
    Sep 22, 2001
    Messages:
    777
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Spain
    Could you run this
    # ls -l /usr/local/cpanel/3rdparty/mailman/lists/info_domain.com/config.db
    and tell us the result?

    I think it should be -rw-rw---- 1 mailman mailman etc.

    Wasn't there a script to fix Mailman's file permissions?
     
  3. webdave

    webdave Active Member

    Joined:
    Jul 4, 2002
    Messages:
    25
    Likes Received:
    0
    Trophy Points:
    1
    Try this:

    Move current /usr/local/cpanel/3rdparty/mailman to
    /usr/local/cpanel/3rdparty/mailman-old

    Run /scripts/upcp

    Move the data, archives, and lists directories under mailman-old to the new mailman directory.

    This should fix the problem.
     
Loading...

Share This Page