Bug in Mailman version 2.1.11.cp3

SomeoneX

Member
Aug 24, 2008
9
0
51
Whenever I access http://www.domain.com/mailman/listinfo, I get this:

Bug in Mailman version 2.1.11.cp3

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.
I checked mailman's error logs, but it shows nothing.

Is there anyway to fix this? The thing is, this happens to all domains hosted in the server (across resellers as well).

cPanel/WHM Version: cPanel 11.24.4-S35075 - WHM 11.24.2

Thanks.
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,216
10
313
Houston, TX
cPanel Access Level
Root Administrator
Is there already a solution for this problem?

I have the same problem. So it seems this is a bug/problem in cPanel.

Here someone says in Spanish that it is a permission problem?!? http://blog.pcastro.net/2009/03/30/mailman-were-sorry-we-hit-a-bug/
Try the following scripts to resolve this issue (in the order below):

Code:
/usr/local/cpanel/3rdparty/bin/check_db
/usr/local/cpanel/3rdparty/bin/check_perms
If that does not resolve the issue, try:

Code:
/scripts/reinstallmailman --force
If all of that doesn't work, please let our technical analysts assist you: http://tickets.cPanel.net/submit
 

LluisForns

Registered
May 25, 2009
4
0
51
Try the following scripts to resolve this issue (in the order below):

Code:
/usr/local/cpanel/3rdparty/bin/check_db
/usr/local/cpanel/3rdparty/bin/check_perms
If that does not resolve the issue, try:

Code:
/scripts/reinstallmailman --force
If all of that doesn't work, please let our technical analysts assist you: http://tickets.cPanel.net/submit
Does any of theses solutions remove mailman configuration? Before trying them I must know if I lists will be deleted or their configuration restored to default.
 

LluisForns

Registered
May 25, 2009
4
0
51
Code:
/usr/local/cpanel/3rdparty/bin/check_db
/usr/local/cpanel/3rdparty/bin/check_perms
/scripts/reinstallmailman
chmod 02775 -R /usr/local/cpanel/3rdparty/mailman/
None of this worked for me; and I have been unable to find logs to check what is happening.

Any other hint?
 

LluisForns

Registered
May 25, 2009
4
0
51
My host told me they had done. I didn't checked.
I have finally found the log of the error:
Code:
May 25 15:16:28 2009 admin(11710): @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@
admin(11710): [----- Mailman Version: 2.1.11.cp3 -----]
admin(11710): [----- Traceback ------]
admin(11710): Traceback (most recent call last):
admin(11710):   File "/usr/local/cpanel/3rdparty/mailman/scripts/driver", line 101, in run_main
admin(11710):     main()
admin(11710):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/admin.py", line 174, in main
admin(11710):     change_options(mlist, category, subcat, cgidata, doc)
admin(11710):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/admin.py", line 1434, in change_options
admin(11710):     mlist.ApprovedDeleteMember(user, whence='member mgt page')
admin(11710):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 1041, in ApprovedDeleteMember
admin(11710):     subject = _('%(realname)s unsubscribe notification')
admin(11710):   File "/usr/local/cpanel/3rdparty/mailman/Mailman/i18n.py", line 90, in _
admin(11710):     return tns % dict
admin(11710): ValueError: incomplete format
admin(11710): [----- Python Information -----]
admin(11710): sys.version     =   2.4.3 (#1, Sep  3 2006, 19:35:45)
[GCC 3.4.6 20060404 (Red Hat 3.4.6-3)]
admin(11710): sys.executable  =   /usr/local/bin/python2.4
admin(11710): sys.prefix      =   /usr/local
admin(11710): sys.exec_prefix =   /usr/local
admin(11710): sys.path        =   /usr/local
admin(11710): sys.platform    =   linux2
admin(11710): [----- Environment Variables -----]
admin(11710):   HTTP_REFERER: http://causantsadurni.org/mailman/admin/caps.castors_causantsadurni.org/members
admin(11710):   SERVER_SOFTWARE: Apache
admin(11710):   SCRIPT_NAME: /mailman/admin
admin(11710):   REQUEST_METHOD: POST
admin(11710):   HTTP_KEEP_ALIVE: 300
admin(11710):   SERVER_PROTOCOL: HTTP/1.1
admin(11710):   QUERY_STRING:
admin(11710):   CONTENT_LENGTH: 5417
admin(11710):   HTTP_ACCEPT_CHARSET: ISO-8859-1,utf-8;q=0.7,*;q=0.7
admin(11710):   HTTP_USER_AGENT: Mozilla/5.0 (Windows; U; Windows NT 5.1; ca; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
admin(11710):   HTTP_CONNECTION: keep-alive
admin(11710):   HTTP_COOKIE: caps.castors_causantsadurni.org+admin=28020000006985941a4a732800000063353235363763306330623039356231663033356533646532356137633866616561613839376438; __utma=42190391.693286380.1237212566.1238141825.1238661848.3; __utmz=42190391.1237212566.1.1.utmccn=(organic)|utmcsr=google|utmctr=%22caps+i+quel%C2%B7les%22|utmcmd=organic; SESSad29aa7522f08ac4b728bc0b540a09b9=560bcc6ca1f9185cdf8925b030bf7fca
admin(11710):   SERVER_NAME: causantsadurni.org
admin(11710):   REMOTE_ADDR: 212.170.53.23
admin(11710):   PATH_TRANSLATED: /home/sansa/public_html/caps.castors_causantsadurni.org/members
admin(11710):   SERVER_PORT: 80
admin(11710):   SERVER_ADDR: 72.232.73.42
admin(11710):   DOCUMENT_ROOT: /home/sansa/public_html
admin(11710):   PYTHONPATH: /usr/local/cpanel/3rdparty/mailman
admin(11710):   SCRIPT_FILENAME: /usr/local/cpanel/3rdparty/mailman/cgi-bin//admin
admin(11710):   SERVER_ADMIN: [email protected]rni.org
admin(11710):   HTTP_HOST: causantsadurni.org
admin(11710):   REQUEST_URI: /mailman/admin/caps.castors_causantsadurni.org/members
admin(11710):   HTTP_ACCEPT: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
admin(11710):   GATEWAY_INTERFACE: CGI/1.1
admin(11710):   REMOTE_PORT: 2959
admin(11710):   HTTP_ACCEPT_LANGUAGE: ca,en-us;q=0.7,en;q=0.3
admin(11710):   CONTENT_TYPE: multipart/form-data; boundary=---------------------------144131664119855
admin(11710):   HTTP_ACCEPT_ENCODING: gzip,deflate
admin(11710):   UNIQUE_ID: ShqaQ0joSSoAACl-514
admin(11710):   PATH_INFO: /caps.castors_causantsadurni.org/members
 

LluisForns

Registered
May 25, 2009
4
0
51
problem solved changing the list language

At last I discovered that my problem was gone if I change the language from catalan to english; so I suppose this is a mailman bug affecting the interface translation.
 

MikeDVB

Well-Known Member
PartnerNOC
Jun 4, 2008
218
3
68
Indiana, USA
This issue seems to keep cropping up - it really needs fixed imho.

This resolves the issue:
chmod 02775 -R /usr/local/cpanel/3rdparty/mailman/
And as such I've set it on a 5 minute cron however cPanel should fix this, is there some sort of bug report we can see so that we will know when it will be resolved/has been resolved?
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,216
10
313
Houston, TX
cPanel Access Level
Root Administrator
This issue seems to keep cropping up - it really needs fixed imho.

This resolves the issue:
And as such I've set it on a 5 minute cron however cPanel should fix this, is there some sort of bug report we can see so that we will know when it will be resolved/has been resolved?
I recommend letting our technical analysts take a look at your server so we can determine what is causing this issue. You can contact our technical analysts at: http://tickets.cPanel.net/submit
 

poa

Registered
Jun 10, 2005
2
0
151
This issue seems to keep cropping up - it really needs fixed imho.

This resolves the issue:
And as such I've set it on a 5 minute cron however cPanel should fix this, is there some sort of bug report we can see so that we will know when it will be resolved/has been resolved?
only chmod 02775 -R /usr/local/cpanel/3rdparty/mailman/cgi-bin every update. :/

Please resolve this issue.
 

cPanelDon

cPanel Quality Assurance Analyst
Staff member
Nov 5, 2008
2,545
12
268
Houston, Texas, U.S.A.
cPanel Access Level
DataCenter Provider
Twitter
only chmod 02775 -R /usr/local/cpanel/3rdparty/mailman/cgi-bin every update. :/

Please resolve this issue.
It sounds like something else is causing this problem to reoccur for you; please submit a ticket (via the link in my forums signature) and PM me the ticket number as I would like to follow-up to ensure this is resolved for you.

To note, the value of "02775" is not valid to the best of my knowledge, but a value of 3 or up to 4 digits is, such as "2755" or "0755" or "755". Within mailman's cgi-bin directory, all files except "create" should be set to chmod 2755 while the create file should be set to chmod 0000.

If the permissions within mailman's cgi-bin are causing the visual symptom, you could use the following command via root SSH access to correct the permissions, but if the problem is reoccurring we will need to investigate further via a ticket:
Code:
# find /usr/local/cpanel/3rdparty/mailman/cgi-bin/* ! -perm 2755 ! -name create -exec chmod -v 2755 '{}' \;
 

RandyO

Well-Known Member
Jun 17, 2003
173
0
166
PHP:
chmod 02775 -R /usr/local/cpanel/3rdparty/mailman/
has resolved my issue (for now) any updates on this ?
 

cjmwebdesigns

Well-Known Member
Dec 20, 2003
72
0
156
New Jersey
cPanel Access Level
Root Administrator
Twitter
Has anyone seen this issue where it is just one customer complaining? I am able to log into the users cPanel through WHM or through cPanel as them and I don't experience the issue, however, my customer has several sites and all of them give him this problem when he logs on.

I find that rather strange.