Bug in Mailman version 2.1.9.cp2

cookiesunshinex

Well-Known Member
Jun 10, 2005
77
0
156
When I got to "tend to pending moderator requests" on my mailman mailing list, I get the following error message.

============
Bug in Mailman version 2.1.9.cp2

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.
============

From the notification emails that I receive, I know that I have about 4500 messages that need to be "discarded." Those are mostly spam messages that are sent to the mailing list.

I go in every couple of months and "discard" them.

I suspect that mailman is running out of memory. Any way to remove all messages that are pending without using the web interface?

I would rather not delete and re-create the list.

Thanks.
 

nichiyume

Member
Nov 18, 2004
18
0
151
Phoenix, Az
I'm trying to set up mailman lists on transfered accounts and I run into the same problem even after running the /scripts, checking my python version, and reinstalling mailman. *scratches head*
 

nichiyume

Member
Nov 18, 2004
18
0
151
Phoenix, Az
admin(27037): [----- Mailman Version: 2.1.9.cp2 -----]
admin(27037): [----- Traceback ------]
admin(27037): Traceback (most recent call last):
admin(27037): File "/usr/local/cpanel/3rdparty/mailman/scripts/driver", line 94, in run_main
admin(27037): pkg = __import__('Mailman.Cgi', globals(), locals(), [scriptname])
admin(27037): File "/usr/local/cpanel/3rdparty/mailman/Mailman/Cgi/admin.py", line 37, in ?
admin(27037): from Mailman import MailList
admin(27037): File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 33, in ?
 

Billa

Member
May 2, 2007
19
0
151
I am facing the same problem.

Tried /scripts/reinstallmailman and /scripts/fixmailman with no luck. and got following errors. :(

Traceback (most recent call last):
File "/usr/local/cpanel/3rdparty/mailman/bin/update", line 789, in ?
errors = main()
File "/usr/local/cpanel/3rdparty/mailman/bin/update", line 679, in main
errors = errors + dolist(listname)
File "/usr/local/cpanel/3rdparty/mailman/bin/update", line 192, in dolist
mlist = MailList.MailList(listname, lock=0)
File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 130, in __init__
self.Load()
File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 640, in Load
dict, e = self.__load(file)
File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 613, in __load
dict = loadfunc(fp)
AttributeError: 'dict' object has no attribute 'append'
Traceback (most recent call last):
File "/usr/local/cpanel/3rdparty/mailman/bin/mailmanctl", line 548, in ?
main()
File "/usr/local/cpanel/3rdparty/mailman/bin/mailmanctl", line 367, in main
check_for_site_list()
File "/usr/local/cpanel/3rdparty/mailman/bin/mailmanctl", line 277, in check_for_site_list
sitelist = MailList(sitelistname, lock=0)
File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 130, in __init__
self.Load()
File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 640, in Load
dict, e = self.__load(file)
File "/usr/local/cpanel/3rdparty/mailman/Mailman/MailList.py", line 613, in __load
dict = loadfunc(fp)
AttributeError: 'dict' object has no attribute 'append'
 

ebinfo

Active Member
Oct 5, 2005
31
0
156
had this bug

for me this bug was due to the fact that python-devel was not installed / properly installed. so it was preventing mailman to work.

i installed python-devel.i386 Rpm, the re-install mailman using the reinstall script found in /scripts/ directory, problem solved.

not sure if it will help with your particular issue but just throught i'd give my 2 cents
 

asiams

Well-Known Member
May 28, 2003
89
0
156
Hokkaido, JAPAN
Not successful yet

Hello,

I have installed rpm for python.devel.i386 from WHM, but this was what it said:


RPM Package Installer

Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Parsing package install arguments
Nothing to do
Install Complete


It seems that this rpm is alreay installed?


I went ahead and reinstall mailman, but this problem persists.

Here is the error logs:

[email protected] [/usr/local/cpanel/3rdparty/mailman/logs]# tail -f error
admin(25431): HTTP_HOST: ast-tech.co.jp
admin(25431): REQUEST_URI: /mailman/admin/ahpp_ast-tech.co.jp/members/add
admin(25431): HTTP_ACCEPT: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
admin(25431): GATEWAY_INTERFACE: CGI/1.1
admin(25431): REMOTE_PORT: 2479
admin(25431): HTTP_ACCEPT_LANGUAGE: ja,en-us;q=0.7,en;q=0.3
admin(25431): CONTENT_TYPE: multipart/form-data; boundary=---------------------------297661602424544
admin(25431): HTTP_ACCEPT_ENCODING: gzip,deflate
admin(25431): UNIQUE_ID: SMCIG0UywVIAAFesGEU
admin(25431): PATH_INFO: /ahpp_ast-tech.co.jp/members/add

Any idea?

Thanks.

asiams
 

asiams

Well-Known Member
May 28, 2003
89
0
156
Hokkaido, JAPAN
Add new member to the list in English but not in Japanese

Hello,

I just tested the mailman with english default setup. And it worked, but when I switched back to Japanese, it did not work with error message with bug.

Anyone had similar experience?

Thanks.

asiams
 

asiams

Well-Known Member
May 28, 2003
89
0
156
Hokkaido, JAPAN
mailman upgrade?

Since current verion of mailman is 2.1.9b, can this be upgraded to 2.1.11?

I am not sure this would resolve the problem, but is there anyone who experienced the similar problem before?

Thanks.

asiams
 

asiams

Well-Known Member
May 28, 2003
89
0
156
Hokkaido, JAPAN
Cpanel was now current

I have updated Cpanel to the most current version to see if it would correct the problem, but the error persists as follow:

Bug in Mailman version 2.1.9.cp2

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.

I have followed the instruction from this thread to reinstall python.devel.i386, but it was already installed. And reinstall mailman from /scripts, but still the problem persists.

It would work if it is in English as default, but when it is set to Japanese, it would kick the error with bug message mentioned above.

Is there any other suggestions?

I have found another thread regarding upgrading to current version of mailman on other thread, but there was no answer regarding this issue of having bug error message.

Any help would be greatly appreciated.

asiams