The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug in Synchronize MySQL password checkbox

Discussion in 'Database Discussions' started by Carlos Fatureto, Sep 3, 2015.

  1. Carlos Fatureto

    Carlos Fatureto Registered

    Joined:
    Sep 3, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    In WHM's "List Account" menu there is a option to change password. If the the account has a .my.cnf file in home directory a checkbox "Synchronize MySQL password" is displayed unchecked by default.

    If the account has no .my.cnf file the checkbox is hidden with default value as "checked".
    So, because the checkbox is hidden you dont know that the "change password" will also synchronize the mysl and you dont have the option to uncheck this checkbox. Sometimes you only want to change the cpanel/ftp password and because of the mysql synchronization the website goes down with a "can not connect to database, login/password is invalid" error.

    What I'm doing is "inspect" (using Chrome) the page, locate the "display:none" CSS and change it to "display:block". Then the checkbox is displayed and I can uncheck it.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    It's advised to utilize a separate database username instead of the cPanel username for databases associated with the account. This ensures a password change is not required when the cPanel account password is changed and it's not synchronized to the MySQL username.

    Thank you.
     
  3. Carlos Fatureto

    Carlos Fatureto Registered

    Joined:
    Sep 3, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    But the usernames are distinct. The cpanel username is only a prefix for mysql users.

    cpanel account: domain.com
    cpanel account user: nmpre065
    mysql user: nmpre065_mysqluser
    mysql user2: nmpre065_usr2

    If I change the nmpre065's password in the WHM the password of users nmpre065_mysqluser and nmpre065_usr2 will also be changed. The only method to not change all mysql users is uncheck the "synchronize MySQL password checkbox", but this checkbox is hidden. This is the bug. The checkbox should not be hidden.
     
    #3 Carlos Fatureto, Sep 4, 2015
    Last edited by a moderator: Sep 8, 2015
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    This is not the default behavior. Have you verified this is the case with a database connection test script? What version of cPanel is installed on this system?

    Thank you.
     
  5. Carlos Fatureto

    Carlos Fatureto Registered

    Joined:
    Sep 3, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Brazil
    cPanel Access Level:
    Root Administrator
    Hi.
    WHM version 11.48.4

    I recorded a video showing what is happening:
    - Removed -
     
    #5 Carlos Fatureto, Sep 7, 2015
    Last edited by a moderator: Sep 8, 2015
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    That shows the account password is changed, but that does not indicate the passwords for individual database users associated with the account are changed. For instance, the password for "$username" is changed, but "$username_databaseuser1" is not changed.

    Thank you.
     
Loading...

Share This Page