The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug: making server-changing actions by clicking on a link

Discussion in 'General Discussion' started by distobj, Sep 21, 2008.

  1. distobj

    distobj Registered

    Aug 29, 2008
    Likes Received:
    Trophy Points:
    There are a number of places in cpanel/WHM where some important action on the server is initiated when a user clicks on an http URL. For example, in "MySQL databases", if I want to delete a database I have to click on a link which results in an HTTP GET message being sent to the server for that link, and the deletion taking place immediately (i.e. no "Are you sure you want to delete it" form with a POST button).

    The problem with this is that later, after my browser had crashed and I resumed my session, that the browser sends - you guessed it - an HTTP GET request to that same URL. Result? No database, and all the data I had imported, and changes I had made, gone.

    I could bore you with what the specification of HTTP 1.1 says about this, but hopefully this single, very practical problem will suffice for cpanel/whm to fix this problem. Database deletion isn't the only place this happens. It's quite common.

  2. chirpy

    chirpy Well-Known Member

    Jun 15, 2002
    Likes Received:
    Trophy Points:
    Go on, have a guess
    If you want to make an enhancement suggestion to cPanel you should log it in as such. Search beforehand as it may already have been suggested.

Share This Page