Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Bug when generating SSL CSR

Discussion in 'General Discussion' started by sneader, Mar 4, 2008.

  1. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,154
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    I've discovered a small bug that I will submit into Bugzilla, but wanted to give you guys a heads up.

    EDIT: Bugzilla submitted: http://bugzilla.cpanel.net/show_bug.cgi?id=6394

    In WHM, under "Generate a SSL Certificate and Signing Request", you are asked to enter in various information for your certificate, as well as a password. There is the new AJAX password creator, for your password generation pleasure.

    HOWEVER, by default, the password generator creates complicated passwords including letters, numbers and SYMBOLS.

    I attempted to use the password it generated, 7B5T#|Wn!Na9, but GeoTrust rejected the CSR, saying "CSR contains unsupported extensions".

    Of course, it took me a while to realize what was going on.

    I generated a new SSL CSR, but used my own password with no symbols, and it worked great.

    I don't know which symbols it has a problem with. But now you know...

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #1 sneader, Mar 4, 2008
    Last edited: Mar 4, 2008
  2. sh4ka

    sh4ka Well-Known Member

    Joined:
    May 12, 2005
    Messages:
    444
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Uruguay
    cPanel Access Level:
    DataCenter Provider
    Thanks, you saved my day!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. rligg

    rligg Well-Known Member

    Joined:
    Sep 16, 2003
    Messages:
    277
    Likes Received:
    0
    Trophy Points:
    166
    You just saved mine as well.
     
  4. cPanelKenneth

    cPanelKenneth cPanel Development
    Staff Member

    Joined:
    Apr 7, 2006
    Messages:
    4,561
    Likes Received:
    42
    Trophy Points:
    308
    cPanel Access Level:
    Root Administrator
    This is fixed in all 11.23 builds and should be fixed in 11.18 also. Hence if you are experiencing this issue you need to update your cPanel install.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. zosorock

    zosorock Member

    Joined:
    Sep 12, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    151
    still happening

    This bug is still happening on cPanel 11.24.5 / WHM 11.24.2

    Just had this problem trying to generate a GeoTrust QuickSSL certificate and using ! in the password.
     
  6. sneader

    sneader Well-Known Member

    Joined:
    Aug 21, 2003
    Messages:
    1,154
    Likes Received:
    38
    Trophy Points:
    178
    Location:
    La Crosse, WI
    cPanel Access Level:
    Root Administrator
    Upgrade to 11.25. Been out for months already. Problem solved.

    - Scott
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice