The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Bug With PHP and Perl at the same time

Discussion in 'General Discussion' started by thesilbi, Dec 31, 2004.

  1. thesilbi

    thesilbi Registered

    Joined:
    Nov 16, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I tried to load the 2 modules on the same Apache Server php and mod_perl.
    I have 2 differents error :
    1/- In my httpd.conf file, in the LoadModule lists, I added the line "LoadModule mod_perl ....." (and the appropriate line in Addmodule...). But, when I tried to restart Apache, i have this error : module perl_module is built-in and can't be loaded. So I commented the LoadModule line, and all worked fine. But....
    2/ ... my perl scripts were ok, but all my php files are being downloaded by my browser. I think PHP module didn't work anymore when mod_perl is enabled.

    Does someone have a solution ?

    Thnaks a lot :)
     
  2. bking

    bking Well-Known Member

    Joined:
    Mar 1, 2004
    Messages:
    206
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Sydney
    Do you have something like:

    AddType application/x-httpd-php .php
    AddType application/x-httpd-php .php4
    AddType application/x-httpd-php .php3
    AddType application/x-httpd-php-source .phps
    AddType application/x-httpd-php .phtml

    in your httpd.conf file?
     
  3. thesilbi

    thesilbi Registered

    Joined:
    Nov 16, 2004
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    In fact, PHP was running well before mod_perl activation.

    So the answer is yes, I have all the required lines in my httpd.conf in order to 'execute' php files.
     
Loading...

Share This Page