bugreport: manage databases doesn't show every database on system

ca2236

Well-Known Member
Feb 2, 2018
216
22
18
Nebraska
cPanel Access Level
DataCenter Provider
Hello,

When you click on manage databases from the list on the left (main cpanel home interface) .. it doesn't show all databases on the system. I'm guessing it only shows databases activity tied to an account. However, if you use the transfer tool and transfer a site, and it messes up in transfer (or you just decide to remove the newly transferred site for some reason) It can seemingly leave behind a database on the system, since this is no longer tied to a username, since the site was removed, it exists on the server, but won't show up in manage databases. I would imagine the same would be true if you created a database on the command line.

I admit, as I type this, I wonder if this is a bug report a feature request. However, it would seem to me that if you have a section called manage databases, it should show all databases on the system. :) (except for mysql/maria default test and users db). I guess it would depend on what the intent of the manage databases was. Either way, in order to remove the rouge database causing issues with future transfers, you have to drop it from the command line.

Thanks!
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,151
523
273
cPanel Access Level
Root Administrator
Hey there! The cPanel interface would only show databases linked to that user's account, as database creation should be performed through the cPanel interface.

If you have a database that isn't linked to an account, can you try using the WHM >> Database Map Tool to get that linked to the correct account?

If you have steps that you can provide on how to recreate the issue I'd be happy to do some testing on my end.