Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

bugs with 5.2.1 , not with 5.2.0

Discussion in 'General Discussion' started by gdns, Feb 19, 2007.

  1. gdns

    gdns Active Member

    Joined:
    Feb 12, 2007
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    151
    we have seen a few bugs suddenly with implementing php 5.2.1

    eg:
    Warning: session_start() [function.session-start]: SAFE MODE Restriction in effect. The script whose uid/gid is 1065/1066 is not allowed to access /var/tmp owned by uid/gid 0/0 in /usr/home/n98729/public_html/startside.php on line 101

    Fatal error: session_start() [<a href='function.session-start'>function.session-start</a>]: Failed to initialize storage module: files (path: ) in /usr/home/n98729/public_html/startside.php on line 101

    and:
    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 862731 bytes) in /usr/home/forumgr/public_html/Sources/Subs-Package.php on line 1552


    so right now we do a rollback..

    It's a much standard cpanel installation, anyone else seen this "errors" ?

    cpanel version: 10.9.0-R118
    freebsd: 6.2-stable
     
    #1 gdns, Feb 19, 2007
    Last edited: Feb 19, 2007
  2. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    166
    Same here

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 19456 bytes) in /home/user/public_html/modules/user/user.module on line 501
     
  3. carluk

    carluk Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    166
    Increase your memory limit then...
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,460
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    The newer version imposes the memory limits set in /usr/local/lib/php.ini you need to edit that and increase the value of:

    memory_limit = 8M

    Then restart httpd.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. gdns

    gdns Active Member

    Joined:
    Feb 12, 2007
    Messages:
    29
    Likes Received:
    0
    Trophy Points:
    151
    fix:
    session.save_path = /path/to/sessions

    .. have to be set (change from 5.2.0 -> 5.2.1) just make this:
    mkdir /var/tmp/phpsession
    chmod 777 /var/tmp/phpsession

    .. remember that php does NOT houseclean this..

    ; NOTE: If you are using the subdirectory option for storing session files
    ; (see session.save_path above), then garbage collection does *not*
    ; happen automatically. You will need to do your own garbage
    ; collection through a shell script, cron entry, or some other method.
    ; For example, the following script would is the equivalent of
    ; setting session.gc_maxlifetime to 1440 (1440 seconds = 24 minutes):
    ; cd /path/to/sessions; find -cmin +24 | xargs rm


    regarding the memory problem, raise the mem limit as mentioned above fixes it..



    the last unmention problem is this:

    Warning: rmdir(xphpxxx) [function.rmdir]: No such file or directory in /usr/home/molberg/public_html/test/php.php on line 10

    Warning: mkdir() [function.mkdir]: SAFE MODE Restriction in effect. The script whose uid/gid is 1006/65534 is not allowed to access / owned by uid/gid 0/0 in /usr/home/molberg/public_html/test/php.php on line 13

    Warning: rmdir() [function.rmdir]: SAFE MODE Restriction in effect. The script whose uid/gid is 1006/65534 is not allowed to access / owned by uid/gid 0/0 in /usr/home/molberg/public_html/test/php.php on line 14
    <html>
    <head>
    <title>Untitled</title>
    </head>

    <body>
    <?
    error_reporting(E_ALL ^ E_NOTICE);

    rmdir("xphpxxx");
    mkdir("xphpxxx", 0777);
    rmdir("xphpxxx");
    mkdir("xphpxxx", 0777);
    rmdir("xphpxxx");

    highlight_file( __FILE__ );
    ?>


    </body>
    </html>

    it actualy got better, now it's obvious that php is trying to access / of the harddrive.. its actualy got better from 5.2.0 that just pumped out some strange error..

    anyone seen this? (or just test the code above)

    Freebsd 6.2 / cpanel 10.9.0 R139
     
  6. Compubuster

    Compubuster Well-Known Member

    Joined:
    Mar 31, 2004
    Messages:
    87
    Likes Received:
    0
    Trophy Points:
    156
    cPanel Access Level:
    Root Administrator
    Same here :

    running : PHP 5.2.1, Apache 1.37 on RHE3

    Tried everything, nothing worked, so downgraded to 5.2.0
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. rpmws

    rpmws Well-Known Member

    Joined:
    Aug 14, 2001
    Messages:
    1,824
    Likes Received:
    7
    Trophy Points:
    318
    Location:
    back woods of NC, USA
    well we just moved all of our production boxes from RHE3 single xeons' and php 5.1.4 to RHE4_64 bit quad core boxes and went to php5.2.1 and noticed a few things as well. drupal for instance will eat the hell out of the memory limit. Nick@cpanel took my bumb up from 8MB to 24MB and took it to 40MB and my drupal installs started working.. I am however considering going down to 5.2.0
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...
Similar Threads - bugs
  1. Derekn
    Replies:
    2
    Views:
    391
  2. Andrij
    Replies:
    9
    Views:
    1,291

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice