mtindor

Well-Known Member
Sep 14, 2004
1,417
82
178
inside a catfish
cPanel Access Level
Root Administrator
I'm running WHM 11.23.2 cPanel 11.23.3-R25971

At first I wondered what was wrong with that response, but then I did some investigating.

Adding the full SPF record from WHM / Edit DNS is no problem - works fine.

Adding the record of yours via Cpanel / Email Authentication yields a problem. There is a field length limit apparently.

I started by adding the IP address and the netblock. Saved it. everything fine. Then added cerberus.carbidefinger.net. Saved it. Worked fine. Then added voodoo.carbidefinger.net. Saved it. Worked fine.

Then added moon.carbidefinger.net. Saved it. Everything fine.

Cpanel interface reported:
Your raw SPF record is : v=spf1 a mx ip4:209.240.24.1 a:cerberus.carbidefinger.net a:voodoo.carbidefinger.net a:moon.carbidefinger.net ip4:89.20.200.32/27 ?all

dig domain.com txt revealed:
"v=spf1 a mx ip4:xxx.xxx.xx.x a:cerberus.carbidefinger.net a:voodoo.carbidefinger.net a:moon.carbidefinger.net ip4:89.20.200.32/27 ?all"

Then added bonham.carbidefinger.net. Saved it. Problem!

Cpanel interface reported:
Your raw SPF record is : v=spf1 a mx ip4:xxx.xxx.xx.x a:cerberus.carbidefinger.net a:voodoo.carbidefinger.net a:moon.carbidefinger.net a:bonham.carbidefinger.net ip ?all

dig domain.com txt revealed:
"v=spf1 a mx ip4:209.240.24.1 a:cerberus.carbidefinger.net a:voodoo.carbidefinger.net a:moon.carbidefinger.net a:bonham.carbidefinger.net ip ?all"

Take a look - it's obviously an issue with some field in the Cpanel interface not allowing over a certain number of entries to be added - It's a space issue. It adds the record to DNS but limits it.

So it may be an issue / bug. Most people probably don't notice it beacuse they likely don't add that much via the Cpanel interface.

NOTE: I have no idea what the limitation is of a TXT record itself. Perhaps Cpanel knows there is a limitation on the length of a TXT record. Or, it could simply be that the Cpanel folks need to fix this one. It may be that TXT records can only be a certain length (perhaps 255 chars to the right of the TXT in DNS).

So don't jump to conclusions yet. But yeah, the response was a little abrupt. That wasn't a response to a support ticket though, so I wouldn't be bothered nearly as much as I would if I got blown off that easily on a support ticket.

Mike
 

nickp666

Well-Known Member
Jan 28, 2005
769
2
168
/dev/null
Thanks for clarifying that it isnt only me seeing it.


I posted it here just to highlight how little is actually done when people post bugs, I made a point of checking it on a few servers before I actually posted it, so its not like its a wild goose chase for them, I was just annoyed that the bug request was not even looked at properly, or what I was saying even challenged in the slightest.


With that said I do understand the frustration software dev teams encounter from mis-reported bugs due to user errors etc, but I dont report bugs unless I know for sure they exist!
 

koolcards

Well-Known Member
Oct 8, 2003
146
0
166
Tampa, Fl
There's no restriction in the RFC:
http://tools.ietf.org/html/rfc1464
5. Restrictions


Some DNS server implementations place limits on the size or number of
TXT records associated with a particular owner. Certain
implementations may not support TXT records at all.
But BIND9 does:
http://www.isc.org/sw/bind/bind8-9_migration.php
2.6. TXT records are no longer automatically split.

Some versions of BIND accepted strings in TXT RDATA consisting of more
than 255 characters and silently split them to be able to encode the
strings in a protocol conformant way. You may now see errors like this
dns_rdata_fromtext: local.db:119: ran out of space
if you have TXT RRs with too longs strings. Make sure to split the
string in the zone data file at or before a single one reaches 255
characters.
So, when there are long TXT lines, break them "\"