The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

buildapache not getting too far

Discussion in 'EasyApache' started by webignition, Jan 31, 2005.

  1. webignition

    webignition Well-Known Member

    Joined:
    Jan 22, 2005
    Messages:
    1,880
    Likes Received:
    0
    Trophy Points:
    36
    Hi,

    I'm trying to use easyapache to rebuild apache to enabled mod_gzip.

    I've tried through WHM > Server Software > Update Apache and this doesn't really offer fantasic results. The browser just displays a couple of lines of output and then gives up after a minute or so (sorry, I forgot to copy the output - I'll try again if its needed!)

    I then thought of running /scripts/easyapache and seeing what happened.

    When it gets round to running buildapache, I get the following output:

    Code:
     [/scripts]# ./easyapache
    --12:30:58--  http://layer1.cpanel.net/buildapache.sea
               => `buildapache.sea'
    Resolving layer1.cpanel.net... 69.72.164.150, 69.57.175.114
    Connecting to layer1.cpanel.net[69.72.164.150]:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 134,338 [text/plain]
    
    100%[====================================>] 134,338      150.02K/s
    
    12:30:59 (149.63 KB/s) - `buildapache.sea' saved [134,338/134,338]
    
    Creating directory buildapache
    Verifying archive integrity... All good.
    Uncompressing buildapache........................................................................................................................
    Verifying compiler and libs....Sync Source: http://httpupdate.cpanel.net/RELEASE/scripts
    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE/scripts/.cpanelsync.lock....Trying httpupdate.cpanel.net @ 69.72.164.152
    100%......Done
    Fetching http://httpupdate.cpanel.net/cpanelsync/RELEASE/scripts/.cpanelsync.bz2....Trying httpupdate.cpanel.net @ 69.72.164.152
    34%...69%...100%......Done
    Verifying installation....Gathering header information file(s) from server(s)
    Server: Fedora Core 2 - i386 - Base
    After the last line there is no more output.

    I can CTRL-C past this point, which then goes on to the easyapache menu, however I don't want to try changing anything if the script is getting stuck beforehand - simpy speaking as I don't know what is wrong, I don't want to risk anything!

    It used to work fine through both WHM and from an SSH prompt, but now it gets stuck at the point I indicated.

    I even tried the same with APF turned off incase it was causing some problem somewhere.

    Any ideas what's happening? I don't know enough about this to be certain, but my guess is that it's not getting a response from a FC2 server.

    What I really need to know is whether it is safe to continue rebuilding apache after CTRL-C-ing past the line at which the script gets stuck?
     
Loading...
Similar Threads - buildapache getting too
  1. Archmactrix
    Replies:
    5
    Views:
    540

Share This Page