The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Building OpenSSL manually breaks EasyApache

Discussion in 'EasyApache' started by jandafields, May 27, 2009.

  1. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    I built OpenSSL and OpenSSH from source manually for PCI compliance reasons. They both built fine, but now EasyApache has this in the log when running:

    Error: Cannot find SSL header files under /usr

    Here is how I built from source:
    Code:
    tar -zxf openssl-0.9.8k.tar.gz
    cd openssl-0.9.8k
    ./config
    make
    make test
    make install
    
    tar -zxf openssh-4.5p1.tar.gz
    cd openssh-4.5p1
    ./configure --prefix=/usr --sysconfdir=/etc/ssh --with-ssl-dir=/usr/local/src/openssl-0.9.8k --with-pam --with-libs=-ldl --without-zlib-version-check
    make
    make install
    
    

    What should I do at this point so EasyApache will use the new builds?
     
    #1 jandafields, May 27, 2009
    Last edited: May 27, 2009
  2. jandafields

    jandafields Well-Known Member

    Joined:
    May 6, 2004
    Messages:
    426
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Running upcp after building fixes the openssl-devel files.

    However, even though "openssl version" returns 0.9.8.k, apache still uses 0.9.7.a. I realize this has redhat security backports.
     
Loading...

Share This Page