The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Built apache

Discussion in 'EasyApache' started by x7even, Oct 29, 2007.

  1. x7even

    x7even Registered

    Joined:
    Oct 29, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    hi

    i want to build apache. I started to build apache for curl installation. When i started to build it gave errors. Pls help me

    Error :

    ./configure [@curl-7.15.3]...(--libdir=/usr/lib64 --prefix=/usr).... . . . . . . . . . . . . . . . . . . Done

    make [@curl-7.15.3]...(-j 4).... . . . . . . . Done

    make[2]: *** [libcurl.la] Error 1
    make[1]: *** [all] Error 2
    make: *** [all-recursive] Error 1


    make [@curl-7.15.3]...(install).... Done

    make[2]: *** [libcurl.la] Error 1
    make[1]: *** [install] Error 2
    make: *** [install-recursive] Error 1

    Using newyum support...
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Nothing to do
    Fetching http://httpupdate.cpanel.net/buildapache/1/php-4.4.7.tar.gz (0)....@69.72.164.152......connected......receiving...1%...2%...3%...4%...5%...6%...7%...8%...9%...10%...11%...12%...13%...14%...15%...16%...17%...18%...19%...20%...21%...22%...23%...24%...25%...26%...27%...28%...29%...30%...31%...32%...33%...34%...35%...36%...37%...38%...39%...40%...41%...42%...43%...44%...45%...46%...47%...48%...49%...50%...51%...52%...53%...54%...55%...56%...57%...58%...59%...60%...61%...62%...63%...64%...65%...66%...67%...68%...69%...70%...71%...72%...73%...74%...75%...76%...77%...78%...79%...80%...81%...82%...83%...84%...85%...86%...87%...88%...89%...90%...91%...92%...93%...94%...95%...96%...97%...98%...99%...100%......Done
    Untarring php....Done
    x86_64 detected.. patching/rebuilding php configure .....patching file acinclude.m4
    patching file acinclude.m4.orig
    patching file ext/domxml/config.m4
    patching file ext/gd/config.m4
    patching file ext/gettext/config.m4
    patching file ext/imap/config.m4
    patching file ext/imap/config.m4.orig
    patching file ext/ldap/config.m4
    patching file ext/mysql/config.m4
    patching file ext/pgsql/config.m4
    patching file ext/snmp/config.m4
    patching file ext/xml/config.m4
    patching file ext/xmlrpc/config.m4
    New Libtool detected.. applying patch! ....patching file acinclude.m4
    Hunk #1 succeeded at 806 with fuzz 2 (offset -15 lines).
    You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
    Forcing buildconf
    using default Zend directory
    buildconf: checking installation...
    buildconf: autoconf version 2.59 (ok)
    buildconf: Your version of autoconf likely contains buggy cache code.
    Running cvsclean for you.
    To avoid this, install autoconf-2.13.
    rebuilding aclocal.m4
    rebuilding configure
    rebuilding main/php_config.h.in
    autoheader: WARNING: Using auxiliary files such as `acconfig.h', `config.h.bot'
    autoheader: WARNING: and `config.h.top', to define templates for `config.h.in'
    autoheader: WARNING: is deprecated and discouraged.
    autoheader:
    autoheader: WARNING: Using the third argument of `AC_DEFINE' and
    autoheader: WARNING: `AC_DEFINE_UNQUOTED' allows to define a template without
    autoheader: WARNING: `acconfig.h':
    autoheader:
    autoheader: WARNING: AC_DEFINE([NEED_FUNC_MAIN], 1,
    autoheader: [Define if a function `main' is needed.])
    autoheader:
    autoheader: WARNING: More sophisticated templates can also be produced, see the
    autoheader: WARNING: documentation.
    Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 729 (offset 184 lines).
    Hunk #2 succeeded at 916 (offset 31 lines).
    Running configure:
    LDFLAGS="-L/usr/X11R6/lib64" /home/cpapachebuild/buildapache/callbacklog --prog configure --dir /home/cpapachebuild/buildapache/build-log -- --enable-pic --with-apxs=/usr/local/apache/bin/apxs --with-libdir=lib64 --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib

    ./configure [@php-4.4.7]...(--enable-pic --with-apxs=/usr/local/apache/bin/apxs --with-libdir=lib64 --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . Done

    make [@php-4.4.7]...(-j 4 clean).... Done

    make [@php-4.4.7]...(-j 4).... . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make [@php-4.4.7]...(install).... . . . . . . . Done

    /etc/rc.d/init.d/httpd start: httpd started

    ./configure [@php-4.4.7]...(--enable-pic --with-libdir=lib64 --prefix=/usr --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --with-gettext --enable-magic-quotes --with-mysqli --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make [@php-4.4.7]...(-j 4 clean).... Done

    make [@php-4.4.7]...(-j 4).... . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make [@php-4.4.7]...(install).... . . . . . . . Done

    initfpsuexec: using apache 1.x support
    PHP version file has been updated to 4.4.7
    ./build all
    ./build install
    initfpsuexec: using apache 1.x support

    Attempting to restart httpd

    Waiting for httpd to restart....
     
Loading...

Share This Page