The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

CageFS and AutoResponders

Discussion in 'CloudLinux' started by cPanelMichael, Oct 8, 2015.

  1. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    CloudLinux has issued a resolution for issues relating to autoresponders and email piping that occurred after the previous update. Users can run the following command to update:

    Code:
    yum clean all
    yum update lve-wrappers
    The official article from Cloud Linux is available at:

    http://www.cloudlinux.com/blog/clnews/lve-wrappers-updated.php

    Thank you.

     
  2. sumi21kav

    sumi21kav Member

    Joined:
    Apr 16, 2011
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    In my case this did not help.

    We have multiple servers and we start facing issue from the last cpanel update 11.50.2.2 on all servers at the same time.

    Not just autoresponders but mail pipe is not working in general. our WHMCS system is not managing the ticket when mail is received because of this.
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  4. sumi21kav

    sumi21kav Member

    Joined:
    Apr 16, 2011
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Yes that's how it is configured and it was working for long time without issue until today when cpanel updated to 11.50.2.2 and it just stop working.
     
  5. kens6139

    kens6139 Active Member

    Joined:
    Dec 21, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chattanooga, Tennessee, United
    cPanel Access Level:
    Root Administrator
    Same issues here, since 11.50.2.2 all of our servers fail autoresponders, unless they are outside cagefs

    yum clean all / yum update lve-wrappers no help
     
  6. DeepXP

    DeepXP Well-Known Member

    Joined:
    Feb 20, 2005
    Messages:
    65
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Internet
    cPanel Access Level:
    Root Administrator
    I removed cageFS, installed it again. It worked for me.
     
  7. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Please post the output from:

    Code:
    rpm -qa | grep lve-wrappers
    Also, check to see if running the "/usr/sbin/cagefsctl --update" command helps.

    Thank you.
     
  8. kens6139

    kens6139 Active Member

    Joined:
    Dec 21, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chattanooga, Tennessee, United
    cPanel Access Level:
    Root Administrator
    rpm -qa | grep lve-wrappers
    lve-wrappers-0.6-6.el6.cloudlinux.x86_64

    Uninstall / Reinstall did not work either

    Working with Antom at CloudLinux

    # chmod 555 /bin
    # chmod 555 /usr/bin
    # cagefsctl --force-update

    This fixed the Auto responder and email piping issues for me.

    I still have issues with SFTP to accounts inside CageFS we are working on.....
     
  9. kens6139

    kens6139 Active Member

    Joined:
    Dec 21, 2003
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Chattanooga, Tennessee, United
    cPanel Access Level:
    Root Administrator
    Update to fix for me

    Reset permissions of /usr and /usr/bin to 755

    Delete all old autoresponders - - example : /home/USER/.autoresponder.useremail@userdomain.com.data

    The Current autoresponders in "/home/USER/.autorespond/" folder work fine
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I am happy to see the issue is now addressed. Thank you for updating this thread with the details of your correspondence with Cloud Linux.

    Thank you.
     
  11. mwaraitch

    mwaraitch Active Member

    Joined:
    Jan 28, 2007
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Islamabad
    cPanel Access Level:
    Root Administrator
    Tried all of the above, none worked.
    The email piping issue continues in varying ways.
    For tickets generated through email piping at whmcs, the users are getting 2 email responses ie. auto responder (set at whmcs) and a bounced back emails with mail delivery failure notice.
    WHMCS team when consulted mentions it as "cloud not exiting properly", while my server admin says, the piping is working (as emails are being piped through and tickets created), so the issue lies with php scripts.
    Trying to find a resolution.
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    We can take a closer look, but I will need additional information on how to direct your support request. Is your Cloud Linux license purchased directly from Cloud Linux or through cPanel?

    Thank you.
     
  13. mwaraitch

    mwaraitch Active Member

    Joined:
    Jan 28, 2007
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Islamabad
    cPanel Access Level:
    Root Administrator
    Update: I can share my part of the experience, may be its useful. However, please bear in mind that I am an end user with very little know how of back end scripts.

    Problem:

    CloudLinux + Cpanel + probably some server configuration (which I don't know) causing bouncing of the emails send to support departments created within WHMCS - Piping done using forwarding. The error message (given at the bottom) indicates failure to locate pipe.php / its directory.

    Probable Reason:
    WHMCS suggests command for use in Cpanel Email Forwarding for piping :
    | php -q /home/username/public_html/whmcs/crons/pipe.php

    WHMCS clarifies use of only public_html/whmcs/crons/pipe.php at related location in Cpanel's. The earlier part i.e. | php -q /home/username/public_html/ and related piping is achieved through appropriate combination of WHMCS scripts with Cpanel.

    During past usage of whmc and cpanel, I noticed that once we put public_html/whmcs/crons/pipe.php in forwarding section of Cpanel, the remaining part including | php -q will automatically appear. However, recently | php -q part does not show up. (at least so in my case)

    WHMCS does not provide any guidelines on this | php -q / part, i.e where and how to insert it (or even inset it or leave it). The WHMCS staff during inspection in response to my support ticket on this, did not indicate the need of | php -q and I may highlight that I created a support ticket with WHMCS and followed it up. The WHMCS team however, insisted that it pertain to cloud not existing properly.

    Resolution:
    A cpanel post at email pipe fine but still generate and send bounce email back to sender helped me to know that editing of this can be achieved from /etc/valiases/yourdomain.com file directly
    Thats what I did, added php -q in valises.

    This is just my personal experience which if applies to some one else to make use of.
    I am closely watching the corn jobs (which also have similar path without php -q to see how does it go.

    ---------error message in bounced emails --

    pipe to |/home/username/public_html/support/crons/pipe.php
    generated by abc@domainname
    local delivery failed

    The following text was generated during the delivery attempt:

    ------ pipe to |/home/username/public_html/support/crons/pipe.php
    generated by abc@domainname ------

    cagefs_enter: /home/username/public_html/support/crons/pipe.php: No such file or directory
     
  14. mwaraitch

    mwaraitch Active Member

    Joined:
    Jan 28, 2007
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Islamabad
    cPanel Access Level:
    Root Administrator
    Thanks, Michael, it is resolved already.
     
  15. Havri

    Havri Member

    Joined:
    Oct 28, 2013
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Website Owner
    Hello,

    For me the uninstall method worked on one server so far. I first disabled and removed all directories associated with CageFS:

    /usr/sbin/cagefsctl --remove-all

    Uninstall it:
    yum remove cagefs

    yum clean all

    Install it back:
    yum install cagefs

    Go to WHM -> CageFS -> Initialize

    cagefsctl --force-update

    After that, I tried again to see if the autoresponse works, and it does (so far). I will try it on some other servers which are encountering the same problem. Will come back if I find anything different.

    P.S. Don't forget to enable CageFS for all the users after init from WHM.

    Hope this helps somebody.
     
    #15 Havri, Nov 26, 2015
    Last edited: Nov 26, 2015
  16. Havri

    Havri Member

    Joined:
    Oct 28, 2013
    Messages:
    14
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Website Owner
    Hello,

    A solution to this was to remove the eximmailtrap file:

    mv /etc/eximmailtrap /etc/eximmailtrap.bak

    service exim restart

    Regards.
     
Loading...

Share This Page