The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cagefs and memory limit error

Discussion in 'CloudLinux' started by lldeepakll, Sep 18, 2012.

  1. lldeepakll

    lldeepakll Well-Known Member

    Joined:
    May 20, 2012
    Messages:
    86
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    I am having problem with one of the my account. On a particular page it is showing below error.

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 328312 bytes) in /home/username/public_html/DEMO/2012/MarketClick/wp-content/plugins/wp-e-commerce/wpsc-core/wpsc-deprecated.php on line 141

    when I disable cagefs for this user the problem solved out but if I enable cagefs for this user it produce above error. I have also tried with increasing memory limit in php.ini and also increase the memory for this user in cloud linux Lve manager. The problem is only with this particular user only.
    Please help me solve this.

    Thanks.
     
  2. lldeepakll

    lldeepakll Well-Known Member

    Joined:
    May 20, 2012
    Messages:
    86
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi, Finally issue has been resolved. using following steps:

    Just increased memory_limit in /usr/local/lib/php.ini to 128M

    After that I have updated this file in CageFS, using the following command:
    echo "/usr/local/lib/php.ini"| cagefsctl --update-list “

    And issue got resolved. :)
     
Loading...

Share This Page