caldav & carddav DNS entries not updating after server hostname change

akust0m

Well-Known Member
Feb 19, 2016
72
4
58
Melbourne
cPanel Access Level
Root Administrator
Hello,

I recently moved my development cPanel server into production and as a result I needed to perform a hostname change.

Since doing the hostname change, everything has worked well except the caldav and carddav SRV records are still showing the old server hostname 3 days later for all domains.

How can I fix this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
Hello :)

You can disable the following option in "WHM >> Tweak Settings" under the "Domains" tab:

"Thunderbird and Outlook autodiscover and autoconfig support (enables proxy subdomain and SRV record creation)"

Then, after saving the change, browse back to "WHM >> Tweak Settings" under the "Domains" tab again, and enable the following options:

"Thunderbird and Outlook autodiscover and autoconfig support (enables proxy subdomain and SRV record creation)"
"Overwrite custom SRV records used by Outlook AutoDiscover support"

Upon saving this change, the SRV records in the zones should reflect the new hostname.

Thank you.
 

akust0m

Well-Known Member
Feb 19, 2016
72
4
58
Melbourne
cPanel Access Level
Root Administrator
Hello :)

You can disable the following option in "WHM >> Tweak Settings" under the "Domains" tab:

"Thunderbird and Outlook autodiscover and autoconfig support (enables proxy subdomain and SRV record creation)"

Then, after saving the change, browse back to "WHM >> Tweak Settings" under the "Domains" tab again, and enable the following options:

"Thunderbird and Outlook autodiscover and autoconfig support (enables proxy subdomain and SRV record creation)"
"Overwrite custom SRV records used by Outlook AutoDiscover support"

Upon saving this change, the SRV records in the zones should reflect the new hostname.

Thank you.
Thank you, that has solved my issue.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,226
463
I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.