The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can create account, but not login to cpanel or ftp

Discussion in 'General Discussion' started by sagehost, Jan 8, 2010.

  1. sagehost

    sagehost Active Member

    Joined:
    Feb 11, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I'm running cPanel/WHM 11.25.0-R42399 on my server with ThePlanet. I am able to log into WHM, create a new account and according to the on screen messages everything is completed in the account creation with no issue.

    When I try to go to domainname.com/cpanel and enter in the username and password cpanel comes back with the same username password prompt as if the password is incorrect.

    When I try to log into the FTP of this new account I'm also unable to log into the account - I get the following error message "530 Login authentication failed", I'm using FileZilla for my ftp client.

    When I go back into WHM and try to reset the password just to something else for testing purposes I get this error from WHM: "The password for 'username' could not be changed because:" there is no "because" reason listed, that's all that's shown on the page.

    I can delete the account and re-create the account but only get the same results.

    Any suggestions?
     
  2. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Are you sure you don't receive any error message while creating an account? And also tail the cPanel error logs while changing the password to see if you receive any error message there

     
  3. sagehost

    sagehost Active Member

    Joined:
    Feb 11, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I again tried to change the password to the account and then immeditily checked the log file as suggested above and this is the result:

    Code:
    
    [2010-01-08 08:40:46 -0600] warn [Cpanel::FileUtils::TouchFile] Failed to create /var/cpanel/userhomes/cpanel/cpanelbranding/timedata: No such file or directory at /usr/local/cpanel/Cpanel/FileUtils/TouchFile.pm line 72
            Cpanel::FileUtils::TouchFile::touchfile('/var/cpanel/userhomes/cpanel/cpanelbranding/timedata') called at /usr/local/cpanel/Cpanel/Branding/Lite.pm line 450
            Cpanel::Branding::Lite::_clearcache() called at /usr/local/cpanel/Cpanel/ModReg.pm line 126
            Cpanel::ModReg::rebuildsprites('x3mail', 'method=scale_60percent,format=png,imgtype=icon,subtype=img|format=jpg,compression=95,imgtype=icon,subtype=img|subtype=img,imgtype=ui,format=png|subtype=img,imgtype=ui,method=skip_filetype_gif,format=jpg,compression=95|subtype=img,imgtype=ui,method=only_filetype_gif,format=gif', 0) called at /usr/local/cpanel/bin/rebuild_sprites line 58
    Can't locate Crypt/PasswdMD5/XS.pm in @INC (@INC contains: /scripts /usr/lib/perl5/5.8.8/i686-linux /usr/lib/perl5/5.8.8 /usr/lib/perl5/site_perl/5.8.8/i686-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7/i686-linux /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.4/i686-linux /usr/lib/perl5/site_perl/5.8.4 /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site_perl/5.6.2 /usr/lib/perl5/site_perl .) at /scripts/cPScript/CheckPass/UNIX.pm line 6.
    BEGIN failed--compilation aborted at /scripts/cPScript/CheckPass/UNIX.pm line 6.
    Compilation failed in require at /scripts/cPScript/CheckPass.pm line 6.
    BEGIN failed--compilation aborted at /scripts/cPScript/CheckPass.pm line 6.
    Compilation failed in require at /scripts/realchpass line 16.
    BEGIN failed--compilation aborted at /scripts/realchpass line 16.
    
    
     
  4. marc8358

    marc8358 Registered

    Joined:
    Jan 7, 2010
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I have been facing similar problem...... I need help seriously............


    _____________________
    Personal Trainer London
     
  5. madaboutlinux

    madaboutlinux Well-Known Member

    Joined:
    Jan 24, 2005
    Messages:
    1,052
    Likes Received:
    2
    Trophy Points:
    38
    Location:
    Earth
    Looks like the required perl module is missing. Execute the following command as root to install the module and see if it makes the difference

     
  6. sagehost

    sagehost Active Member

    Joined:
    Feb 11, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Is there any other commands I need to run after running the above, because so far I'm still getting the same results.
     
  7. sagehost

    sagehost Active Member

    Joined:
    Feb 11, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    I'm still having this same issue, any other suggestions would be appreciated.
     
  8. TechBrein

    TechBrein Member

    Joined:
    Jul 31, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Run the following command:
    /scripts/checkperlmodules

    That should install any missing modules.
     
  9. sagehost

    sagehost Active Member

    Joined:
    Feb 11, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    TechBrein, I ran your command as well as:

    service cpanel restart

    and I'm now able to reset users passwords and log into the ftp using that password. All is good now, thanks so much everyone that helped!
     
  10. TechBrein

    TechBrein Member

    Joined:
    Jul 31, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Glad to hear it worked for you, HTH :)
     
  11. Brendon

    Brendon Registered

    Joined:
    Aug 19, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Im having the same exact problem with ftp login for an addon domain account. However the above commands did not work for me. Any other suggestions would be appreciated.
     
  12. TechBrein

    TechBrein Member

    Joined:
    Jul 31, 2006
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Did you see anything useful in the logs (/usr/local/cpanel/logs/error_log)?
     
  13. Brendon

    Brendon Registered

    Joined:
    Aug 19, 2010
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Nothing relevant. I'm baffled. Ive remade the entire add-on domain with the same results. If I make an actual account it works fine. Add-ons do not allow FTP unless logging in from root account. Could this just be a simple directory permissions misconfiguration thing?
     
Loading...

Share This Page