Operating System & Version
CENTOS 6.10 virtuozzo
cPanel & WHM Version
cPanel/WHM is version 86.0.40

harishz3

Member
Sep 16, 2022
20
8
3
India
cPanel Access Level
Website Owner
Hi,

My server is on CENTOS 6.10 virtuozzo & cPanel/WHM is version 86.0.40.

When I look for upgrade options in the "update preferences" I get to select "LTS 102.0.21" will this be a smooth update?
And can I upgrade from CentOS 6 to 7?
 

andrew.n

Well-Known Member
Jun 9, 2020
934
346
63
EU
cPanel Access Level
Root Administrator
Since you are on OpenVZ (Virtuozzo) platform which uses shared kernel, it is not possible to upgrade from CentOS 6 to 7 unfortunately. cPanel tier upgrade from edge to stable etc.. should be working as expected.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
13,382
2,106
363
cPanel Access Level
Root Administrator
I would also add that you should seriously consider migrating to a newer machine, as CentOS 6 has long been end-of-life. Moving to AlmaLinux 8 would provide you with a much more modern hosting solution that would be more secure than your current environment.
 
  • Like
Reactions: andrew.n

harishz3

Member
Sep 16, 2022
20
8
3
India
cPanel Access Level
Website Owner
Thank you for your input.

Yes, I'm considering migrating to a new server, just trying to know if I could update the CentOS 6, So that I can have a smooth migration of data from the old to a new server.
I will install AlmaLinux 8 on the new server if the hosting providers make it available.


Any suggestions on migration/restoration from the old server with CentOS 6 to a new server with AlmaLinux, please do let me know.

Thank you.
 
  • Like
Reactions: andrew.n

harishz3

Member
Sep 16, 2022
20
8
3
India
cPanel Access Level
Website Owner
Hi there, one more thing!

Recently the Old server (centOS) is giving very slow download speeds(around only 700 Kbps) for data transfers over Filezilla/Putty etc. Tried rebooting the server but no change in the download speeds. I expect a minimum of 15 to 20 Mbps speed on my internet connection.

If you can suggest something regarding this, please let me know.
 

harishz3

Member
Sep 16, 2022
20
8
3
India
cPanel Access Level
Website Owner
Ok, thank you.

I just now tried to build the server with AlmaLinux and it has given an error " an unexpected error has occurred"

I just rebuild the server?
 

andrew.n

Well-Known Member
Jun 9, 2020
934
346
63
EU
cPanel Access Level
Root Administrator
You need to ask your hosting provider about this. They might not support the newest Almalinux on their platform yet. If you tried Alma 9 then maybe Alma 8 works.
 
  • Like
Reactions: harishz3

harishz3

Member
Sep 16, 2022
20
8
3
India
cPanel Access Level
Website Owner
Well, it was constructing the cpanel and after that, it gave the error message.
I just opened the hosting providers page on a different browser and I can see the new server with AlmaLinux 8 and WHM.

So, as the server build ended with an error message as mentioned above, shall I rebuild this server? that is my question.
 

harishz3

Member
Sep 16, 2022
20
8
3
India
cPanel Access Level
Website Owner
Hi there,

The new server was set up successfully.
The only issue I'm facing now is the remote server has MySQL version 5.7 and the New server has MySQL 8.
The Transfer Tool is requesting to upgrade MSQL 5.7 to 8.

On the Remote server, the upgrade option (in WHM) I get for MySQL 5.7 is MariaDB 10.2 & 10.3.
The new server (AlmaLinux 8) Not showing MariaDB 10.2 or 10.3 for an upgrade, only shows MySQL, How to add MariaDB to WHM?

Any advice, on how I should move forward on this? Please let me know.
 
Last edited:
  • Like
Reactions: Kent Brockman

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
13,382
2,106
363
cPanel Access Level
Root Administrator
What version of cPanel is the Source server? It may be too old to receive the MySQL 8 update.

You can always try and proceed with how things are, but it's possible some things may not be compatible or there would be database errors in the transfer.

My recommendation? Try transferring one account, even if you don't want it to be live yet, and see if there are MySQL errors. You could then point your local browser to the new system and see if all the database content loads properly.
 

harishz3

Member
Sep 16, 2022
20
8
3
India
cPanel Access Level
Website Owner
Hi,

The source server is on outdated CENTOS 6.10, cPanel: v86.0.40.
Yes, it is too old for MySQL 8, but it gives an option to upgrade to MariaDB 10.2 & 10.3. That's the reason I'm trying to install MariaDB on the New server so that it is a smooth transfer without Database errors.

I will try what you have suggested.