The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

can no longer send mail from one server to the other

Discussion in 'E-mail Discussions' started by audrey, Mar 1, 2011.

  1. audrey

    audrey Well-Known Member

    Joined:
    Oct 18, 2006
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    Two of my servers that are at the same datacenter were rebooted and
    I can no longer send mail from one server to the other.

    sending mail works great on both servers as long as I do not try to send mail to an account on the other server. (in other words - I can send mail to gmail or hotmail or aol - just not the other server)

    receiving mail is not a problem on either server

    this is the error in the mail logs on both servers
    R=lookuphost T=remote_smtp defer (-53): retry time not reached for any host

    Any advice to solve this problem would be greatly appreciated

    Thanks
    Audrey
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Hello Audrey,

    Please try clearing the exim databases that handle the retry times:

    Code:
    /usr/sbin/exim_tidydb -t 1d /var/spool/exim retry > /dev/null 
    /usr/sbin/exim_tidydb -t 1d /var/spool/exim reject > /dev/null 
    /usr/sbin/exim_tidydb -t 1d /var/spool/exim wait-remote_smtp > /dev/null
    Then restart exim at that point. What likely happened is that the two machines couldn't reach each other and now won't try to send mail until the retry time is reached.

    Also, can you telnet on each machine to the other machine on port 25 at this time?

    Code:
    telnet othermachineIP# 25
    Thanks.
     
  3. audrey

    audrey Well-Known Member

    Joined:
    Oct 18, 2006
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    Thank you so much for your quick response!

    Unfortunately it did not solve the problem on either server

    One of the servers can telnet to the other and the other server cannot
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Do you have a firewall running on both servers? Can you try taking the firewall down and re-attempt the telnet on the machine?
     
  5. audrey

    audrey Well-Known Member

    Joined:
    Oct 18, 2006
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    one more thing- I restarted exim in the whm as opposed to ssh
    Do you think that I should stop and start exim in ssh?
    Thanks again
     
  6. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    It is fine to restart it via WHM rather than root SSH, although I normally perform the restart in SSH myself.
     
  7. audrey

    audrey Well-Known Member

    Joined:
    Oct 18, 2006
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    Thanks again for the quick response
    and thanks for letting me know restarting in whm being ok

    the one server has the csf firewall
    I turned it off and the other server can now telnet to the one with the csf firewall.
    So with this csf firewall turned off - both servers can telnet to each other

    the other server just has the firewall that is standard on a linux machine.
    I do not know how to turn it off.

    I tested the email again bn both servers sending to each other when the firewall was off and still no luck - same error
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    You'll have to reclear the database files again and restart exim again, then re-try it now with the firewall turned off.
     
  9. audrey

    audrey Well-Known Member

    Joined:
    Oct 18, 2006
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    I turned off the csf firewall again
    and with the csf firewall turned off
    I cleared the databases again on both servers
    and I stopped and started exim in ssh on both servers
    and I still get the same error in the maillogs when I try to send mail from server to server
     
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Could you try opening up a ticket with us so we can check into this further? Clearing those databases should allow the timeout to be cleared. You can use WHM > Support Center > Contact cPanel or the link in my signature.
     
  11. audrey

    audrey Well-Known Member

    Joined:
    Oct 18, 2006
    Messages:
    72
    Likes Received:
    1
    Trophy Points:
    8
    thanks - will do
     
  12. phetu

    phetu Registered

    Joined:
    Apr 12, 2004
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have the same problem. Is there a solution available?

    Patrick
     
Loading...

Share This Page