The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can not create MySQL database in CPANEL!

Discussion in 'General Discussion' started by anton_latvia, May 17, 2006.

  1. anton_latvia

    anton_latvia Well-Known Member
    PartnerNOC

    Joined:
    May 11, 2004
    Messages:
    348
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Latvia
    cPanel Access Level:
    Root Administrator
    Hi,

    I am running WHM 10.8.0 cPanel 10.8.2-R83, CentOS 4.3 x86_64 - WHM X v3.1.0. It's fresh installation. But it comes with serious problem. I can not create any database in CPANEL. And also I can not add new user. When I try to create it, CPANEL says - no problem, created user/database, but no database/user are being created!.

    What kind of .. is it? :eek:

    Anton
     
  2. anton_latvia

    anton_latvia Well-Known Member
    PartnerNOC

    Joined:
    May 11, 2004
    Messages:
    348
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Latvia
    cPanel Access Level:
    Root Administrator
    Update: There is the following error message in log.
    /usr/bin/perl: symbol lookup error: /usr/lib/perl5/site_perl/5.8.7/x86_64-linux/auto/DBD/mysql/mysql.so: undefined symbol: mysql_init

    How can I fix it without downgrading? And why it is there on the fresh installation?!

    Also when I try to reinstall DBD::mysql I get these errors:

    install_driver(mysql) failed: Can't load '/home/.cpan/build/DBD-mysql-3.0003/blib/arch/auto/DBD/mysql/mysql.so' for module DBD::mysql: /home/.cpan/build/DBD-mysql-3.0003/blib/arch/auto/DBD/mysql/mysql.so: undefined symbol: mysql_stmt_free_result at /usr/lib/perl5/5.8.7/x86_64-linux/DynaLoader.pm line 230.
     
    #2 anton_latvia, May 17, 2006
    Last edited: May 17, 2006
  3. anton_latvia

    anton_latvia Well-Known Member
    PartnerNOC

    Joined:
    May 11, 2004
    Messages:
    348
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Latvia
    cPanel Access Level:
    Root Administrator
    Drew Nichols likes this.
  4. Berbox

    Berbox Well-Known Member

    Joined:
    Apr 4, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Belgium
    It worked.

    Thanks
     
  5. anton_latvia

    anton_latvia Well-Known Member
    PartnerNOC

    Joined:
    May 11, 2004
    Messages:
    348
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Latvia
    cPanel Access Level:
    Root Administrator
    Remember to disable WHM auto-update, otherwise it will overwrite it and tomorrow you will have to run this fix again.
     
  6. ydz.ru

    ydz.ru Registered

    Joined:
    Feb 5, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hello.
    I am running WHM 10.8.0 cPanel 10.9.0-R118
    Fedora i686 - WHM X v3.1.0
    I can too not create any database in CPANEL from any user. And CPANEL says - no problem, created user/database, but no database/user are being created! (copyright by anton_latvia)
    But i have not 64-bit server, and this fix not worked :mad:

    Help me! :confused:
     
  7. anton_latvia

    anton_latvia Well-Known Member
    PartnerNOC

    Joined:
    May 11, 2004
    Messages:
    348
    Likes Received:
    3
    Trophy Points:
    18
    Location:
    Latvia
    cPanel Access Level:
    Root Administrator
    Try:
    Code:
    /scripts/perlinstaller --force Bundle::DBD::mysql
    /usr/local/cpanel/bin/checkperlmodules
    /scripts/upcp --force
    
     
  8. ydz.ru

    ydz.ru Registered

    Joined:
    Feb 5, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thank you! It's worked!
     
  9. Berbox

    Berbox Well-Known Member

    Joined:
    Apr 4, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Belgium
    The problem still comes back even with cPanel Update disabled.
    A shorter way is running following command

    /scripts/mysqlup --force

    This solves the problem by me.
     
  10. nike

    nike Registered

    Joined:
    Jul 9, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    I had same problem, with small different:
    perl Makefile.PL --libs="-L/usr/lib/ -lmysqlclient"

    And it works now, thanks!! :)
     
  11. LP-Tim

    LP-Tim Active Member

    Joined:
    Apr 30, 2007
    Messages:
    26
    Likes Received:
    0
    Trophy Points:
    1
    "/scripts/mysqlup --force" worked today. We'll see how it looks tomorrow.
     
Loading...

Share This Page