The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can not open Port 43?

Discussion in 'Security' started by systemn, May 3, 2016.

  1. systemn

    systemn Member
    PartnerNOC

    Joined:
    Jun 21, 2011
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I have a same problem with csf, i try all option to open port 43 buy still have a status close.

    I do all what need.

    Login with ssh to server , edit

    nano etc/csf/csf.conf

    Found line

    # Allow incoming TCP ports
    TCP_IN = "20,21,22,25,26,37,43,53,80,110,113,443,465,873,2087,2089,2703"


    # Allow outgoing TCP ports
    TCP_OUT = "20,21,22,25,26,37,43,53,80,110,113,443,465,873,2087,2089,2703"

    # Allow incoming UDP ports
    UDP_IN = "20,21,43,53,465,6277,24441"

    # Allow outgoing UDP ports
    UDP_OUT = "20,21,43,53,113,123,465,873,6277,24441,33434:33523"

    And for all 4 i add port 43 .

    After save change and restart

    service csf restart

    But i check again after restart i still have close port 43.

    Any help to do this ?

    Thank you,
     
  2. quizknows

    quizknows Well-Known Member

    Joined:
    Oct 20, 2009
    Messages:
    940
    Likes Received:
    55
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    Do you actually have a service listening on the port? Are you trying to connect out on that port, or accept connections on it? It's easier to help if we know what you are trying to accomplish.

    Last but not least you can rule out any rogue iptables rules if you do a quick disable/re-enable of csf by running:

    csf -x ; csf -e
     
  3. systemn

    systemn Member
    PartnerNOC

    Joined:
    Jun 21, 2011
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Twitter:
    Yes i have whois server and other service witch using this port 43

    I try all option, check port in and out with other servers buy any time i get status close

    I try and this to disable CSF but not work
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    You can verify if a service is listening for connections on this port with a command such as:

    Code:
    netstat -lnp | grep :43
    Also, you may want to consult with your data center or hosting provider to determine if traffic to or from this port is blocked in their own firewall.

    Thank you.
     
  5. systemn

    systemn Member
    PartnerNOC

    Joined:
    Jun 21, 2011
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Twitter:
    I have root server and i Managed this server. I was contacted and Data Center and get information that server not have any blocked port.
     
  6. quizknows

    quizknows Well-Known Member

    Joined:
    Oct 20, 2009
    Messages:
    940
    Likes Received:
    55
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    What is your output of the netstat command cPanelMichael posted? I would advise checking the same, and without that it will be hard to help you further.
     
  7. systemn

    systemn Member
    PartnerNOC

    Joined:
    Jun 21, 2011
    Messages:
    16
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Twitter:
    Hello,

    I stile have a problem with this, now when enter

    Code:
    netstat -lnp | grep :43
    No status, or any other information just back to root.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You may want to try configuring these services to listen on a higher port number to see if that makes a difference. Also, make sure the services you are referring to are running on the system. EX:

    Code:
    ps aux|grep service-name
    Thank you.
     
  9. twhiting9275

    twhiting9275 Well-Known Member

    Joined:
    Sep 26, 2002
    Messages:
    538
    Likes Received:
    15
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Twitter:
    port 43, as I mentioned on WHT isn't going to have anything running on it by default. It should be left open and unused.
    Your CSF configuration is fine . What happens when you try to do an nslookup from inside of your shell? You said that nslookup works fine, correct?

    So, what's the issue?
     
  10. quizknows

    quizknows Well-Known Member

    Joined:
    Oct 20, 2009
    Messages:
    940
    Likes Received:
    55
    Trophy Points:
    28
    cPanel Access Level:
    DataCenter Provider
    This means that no service is bound to that port. In other words, no process is ready to accept connections on that port.
     
Loading...

Share This Page