Can not send email from new server (seems to be using wrong mx records)

larryinfl

Registered
Nov 27, 2005
2
1
153
Hello,

I'm in the process of setting a cpanel server up via my home ATT fiber connection with dedicated IP.

The server is setup and running well, except the server will not send any email. All outbound emails sit in the queue. I can receive email fine.

When I check mail logs for any of the sites on the server they are all trying to use google SMTP servers, not the local server. (ie; mail.domain.com) Any email trying to be sent will timeout due to not being authorized to use the google smtp servers.

I do use google workplace email services for one of my sites on the server. It seems like that may be overriding other sites on the server. I have spent several hours trying things and nothing is working.

I can send email from the domain that uses google workspace email services. I just can't send email from any site that uses the servers email server.

I have all the needed ports open in my firewall and am confident that is not the issue.

Any thoughts?

Larry
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
11,032
1,741
363
cPanel Access Level
Root Administrator
Hey there! The best thing to do would be the following:

-type up a message and get ready to send it
-run this command on the server:
Code:
tail -f /var/log/exim_mainlog
-send the message

That command will show you the mail log in real-time so you can see what the logs report about the mail not sending. It's worth noting that *sending* messages would not be related to the MX records, as those are used for receiving messages.
 

larryinfl

Registered
Nov 27, 2005
2
1
153
Hi cPRex,

After more digging, I'm pretty sure the issue is I need reverse DNS setup. My ISP is ATT and I talked to them about setting up a PTR record. They are currently working on it on their end.

Larry
 
  • Like
Reactions: cPRex