The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can not Send Email to yahoo members

Discussion in 'E-mail Discussions' started by 4402734, Sep 20, 2005.

  1. 4402734

    4402734 Active Member

    Joined:
    Sep 20, 2005
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Hello
    I am new in whm & cpanel.
    When i trying to send email via outlook express and php codes, yahoo cannot receive my messages as Gmail and etc simply receive messages from my server.
    please help me find the problem.
    thanks
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The first thing you need to do is to check the error message that you get in the exim mainlog /var/log/exim_mainlog when you send an email to one of the failing addresses.
     
  3. 4402734

    4402734 Active Member

    Joined:
    Sep 20, 2005
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    How can access these log files?
     
  4. jester.ro

    jester.ro Well-Known Member
    PartnerNOC

    Joined:
    Feb 6, 2004
    Messages:
    304
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Bucharest, Romania
    cPanel Access Level:
    DataCenter Provider
    ssh to the server

    and then keep the console open and issue the command


    tail -f /var/log/exim_mainlog

    and try to send the email.

    check the message, and post it here.
     
  5. 4402734

    4402734 Active Member

    Joined:
    Sep 20, 2005
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Click This link to see an image of this log.
    note that my server cannot send emails just to yahoo emails.

    Thanks
     
    #5 4402734, Sep 20, 2005
    Last edited: Sep 20, 2005
  6. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    It looks like you have an account named yahoo.com set up on your server. Mail intended for yahoo.com addresses will go to this account instead of going to yahoo.com's server.

    When you send a message, exim will first check to see if the domain is set up locally, if it is, it will deliver it and will not have to do any DNS lookups. If that fails, then it proceeds to do DNS and MX lookups and send the message out. From your logs it looks like yahoo.com is set up as a local account. You will probably want to delete that account, unless you have a specific reason for hosting it.
     
  7. 4402734

    4402734 Active Member

    Joined:
    Sep 20, 2005
    Messages:
    42
    Likes Received:
    0
    Trophy Points:
    6
    Really thanks
    Thats right, i have opened an account named yahoo.com

    i fixed the problem and now, my server sends emails to yahoo server too.

    thanks again
     
    #7 4402734, Sep 20, 2005
    Last edited: Sep 20, 2005
  8. -jdk-

    -jdk- Well-Known Member

    Joined:
    Aug 28, 2005
    Messages:
    63
    Likes Received:
    0
    Trophy Points:
    6
    Anyone have the problem when the server goes to send an email to a @yahoo.com or other free email service and the email addy doesn't exist so the mail stays in the mail queue?
     
Loading...

Share This Page