The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can Not Upgrade PHP with Easy Apache

Discussion in 'EasyApache' started by Scott Greczkows, Jun 8, 2007.

  1. Scott Greczkows

    Scott Greczkows Well-Known Member

    Feb 5, 2004
    Likes Received:
    Trophy Points:
    The other night we were upgraded automatically to Cpanel 11.

    Currently we are running WHM 11.1.0 cPanel 11.4.2-C13422
    FREEBSD 6.2-STABLE amd64 - WHM X v3.1.0

    We are using php 4.4.6 however we wish to upgrade to Version 5.2.1
    (which is the latest version shown available in our Easy Apache while we know 5.2.3 is available now)

    Anyways selecting 5.2.1 and the options we need GD, IMAP, PSPELL, FREETYPE and VERSIONING and hitting the Start Build button sets it going.

    Apache is rebuilt however PHP is never upgraded or installed. In fact after doing this the server stops processing / parsing the PHP files instead making the PHP files downloadable (eeek!) the only way to fix this it to run Easy Apache again and reselecting 4.4.6 again.

    I should note that we are running FreeBSD 6.2 which is not officially supported by Cpanel (6.1 is and 6.2 is a bug fix for 6.1) but I dont think this has anything to do with the problem.

    I have not submitted this as a ticket to Cpanel yet, as I dont want them to log in and try doing the upgrade while my machine is being heavily utilized. I want to be able to do it on my own when its safe for me to do so.

    Any ideas or suggestions?
  2. flash7

    flash7 Well-Known Member

    Feb 16, 2004
    Likes Received:
    Trophy Points:
    cd /home
    rm -rf cpapachebuild

    select option 6

Share This Page