The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can Send Email But Can Not Recieve From Outside Accounts (Multiple Email Accounts)

Discussion in 'E-mail Discussions' started by webmasterj, Dec 30, 2007.

  1. webmasterj

    webmasterj Member

    Joined:
    Sep 28, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    Long time reader, first time asker.

    I am currently having a rather nasty issue with my email and have exhausted my own knowledge base and am in need of a bit of advice if someone out there happens to have a minute to read over this, it is much appreciated.

    I am no longer receiving emails on any of my email accounts, there are several websites and email addresses associated with the account.

    I am able to send emails just fine, when I send emails from one of my accounts to another the emails arrive, if I use another account (gmail, hotmail, a friends @domain account, etc they do not arrive)

    I have not been able to find any similar posts, if someone has already taken the time to answer this specific problem please let me know where I can find that post.

    If someone wishes to test the function of sending an email you can try webmasterj@webdesignbyjason.com to do any testing necessary.

    Any help with this situation would be very much appreciated.

    I went into cPanel and there does not seem to be any email filtering of any kind.

    Thanks,

    Webmasterj/Jason
     
    #1 webmasterj, Dec 30, 2007
    Last edited: Dec 30, 2007
  2. RizyDeWino

    RizyDeWino Well-Known Member

    Joined:
    Aug 1, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Planet Earth
    It appear you have already checked basic things which can cause this issue , so next step would be to check the exim logs , what is the error/message for such emails in the logs ?
     
  3. webmasterj

    webmasterj Member

    Joined:
    Sep 28, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ah I think

    [2007-11-15 09:33:38]: error: file is writable by others: ("path shown here"/mail.cgi)

    Might have something to do with it. On second thought that was some time ago, and I fixed it and am still having the email problem.

    You are speaking about the Logs > Error Log correct?
    The other errors from today are only like
    [Sun Dec 30 10:18:00 2007] [error] [client 76.117.65.69] File does not exist: /home/username/public_html/wvwcswimming/404.shtml
    Could those be causing a problem?

    The only errors besides the mail.cgi one that was fixed are File does not exist: errors.

    Any help would be greatly appreciated.
     
    #3 webmasterj, Dec 30, 2007
    Last edited: Dec 30, 2007
  4. RizyDeWino

    RizyDeWino Well-Known Member

    Joined:
    Aug 1, 2005
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Planet Earth
    I am referring to exim main log , i.e. /var/log/exim_mainlog.
     
  5. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    We compiled a list of all possible solutions to email at: http://servertune.com/kbase/entry/34/
     
  6. webmasterj

    webmasterj Member

    Joined:
    Sep 28, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Using putty I can locate the file, is there a way to do it in Cpanel or WHM? so I can actually view it?

    I tried taking a look at the email delivery route and got.

    Email Address Trace
    webmasterj@webdesignbyjason.com
    virtual_user to local directory

    Legend

    Mail Routing Error
    Filter/Alias File
    SMTP Destination
    Local MailBox
     
    #6 webmasterj, Dec 30, 2007
    Last edited: Dec 30, 2007
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,453
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  8. webmasterj

    webmasterj Member

    Joined:
    Sep 28, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Ok from my /var/log/exim_mainlog


    2007-12-30 11:43:00 1J7Vjt-0005EQ-43 Completed
    2007-12-30 11:43:00 1J7Vjk-0005Az-Ce => :blackhole: <908404058.75077989909514@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:00 1J7Vjk-0005Az-Ce Completed
    2007-12-30 11:43:00 1J7Vjk-0005BR-TM => :blackhole: <910080013.19844933353877@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:00 1J7Vjk-0005BR-TM Completed
    2007-12-30 11:43:00 1J7Vjk-00059g-BJ => :blackhole: <776837102.30125656381796@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:00 1J7Vjk-00059g-BJ Completed
    2007-12-30 11:43:00 1J7Vjk-0005BA-TE => :blackhole: <666693789.49415889750184@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:00 1J7Vjk-0005BA-TE Completed
    2007-12-30 11:43:00 1J7Vjl-000584-Ur => :blackhole: <013152944.31298309817765@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:00 1J7Vjl-000584-Ur Completed
    2007-12-30 11:43:01 1J7Vja-0004mD-Ty => :blackhole: <324232436.71312460471913@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:01 1J7Vja-0004mD-Ty Completed
    2007-12-30 11:43:01 1J7VkC-0005ge-3j => :blackhole: <42676b22.4156482@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:01 1J7VkC-0005ge-3j Completed
    2007-12-30 11:43:01 1J7VkC-0005ft-0x => :blackhole: <20112i24.3431128@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:01 1J7VkC-0005ft-0x Completed
    2007-12-30 11:43:01 1J7Vjj-0005CO-OT => :blackhole: <743965692.81365106144298@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:01 1J7Vjj-0005CO-OT Completed
    2007-12-30 11:43:01 1J7Vk9-0005Is-S2 => :blackhole: <881494185.49196479231702@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:01 1J7Vk9-0005Is-S2 Completed
    2007-12-30 11:43:01 1J7Vk9-0005f4-RY => :blackhole: <939600567.34330550529991@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:01 1J7Vk9-0005f4-RY Completed
    2007-12-30 11:43:01 1J7Vjc-0004la-8w => :blackhole: <800726982.85712613873190@bobfoote.com> R=virtual_aliases
    2007-12-30 11:43:01 1J7Vjc-0004la-8w Completed
    2007-12-30 11:43:01 End queue run: pid=1725
    2007-12-30 12:18:04 H=dhcp-0-1c-10-23-28-20.cpe.powergate.ca ([192.168.1.103]) [24.239.3.228] Warning: Sender rate 0.3 / 1h
    2007-12-30 12:18:05 1J93fh-0001Uj-3k <= webmasterj@webdesignbyjason.com H=dhcp-0-1c-10-23-28-20.cpe.powergate.ca ([192.168.1.103]) [24.239.3.228] P=esmtpsa X=TLSv1:AES256-SHA:256 A=fixed_plain:webmaster+webdesignbyjason.com S=684 id=47774569.80306@webdesignbyjason.com
    2007-12-30 12:18:05 1J93fh-0001Uj-3k => webmaster R=virtual_user T=virtual_userdelivery
    2007-12-30 12:18:05 1J93fh-0001Uj-3k Completed


    Ty for the plug in recommendation btw
     
  9. webmasterj

    webmasterj Member

    Joined:
    Sep 28, 2007
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Finally got it figured out Exim stopped delivering messages due to a problem with queuing.

    If you encounter this you may want to restart the service by logging into the server via SSH and running the following command:

    service exim restart


    It worked for me.
     
  10. amaltemara

    amaltemara Member

    Joined:
    Dec 7, 2007
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
Loading...

Share This Page