The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can send email, Cant receive mail

Discussion in 'E-mail Discussions' started by icontact, Aug 23, 2005.

  1. icontact

    icontact Member

    Joined:
    May 25, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    After reading a number of threads to the similar problems I couldnt find a solution for this problem that I'm having.

    Mail is being delivered by the mail server to the recipients when sending from webmail, but cant reply to that same email tried to send reply back from different domain names not on the same server and I get the same results...



    Technical details of permanent failure:
    PERM_FAILURE: SMTP Error (state 10): 550-"The recipient cannot be verified. Please check all recipients of this
    550 message to verify they are valid."

    I've done

    /scripts/eximup --force

    No eximmailtrap to delete
    unticked Verify the existance of email senders

    Im out of ideas anyone with other suggestions...
     
  2. aby

    aby Well-Known Member

    Joined:
    May 31, 2005
    Messages:
    638
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    There are a few more things that you can check

    Trying
    /scripts/mailperm

    Making sure you does have entry in /etc/localdomains

    then having a look at the /etc/resolv.conf

    But most important thing is verifying the mail log. It will give you more clear picture.
     
  3. icontact

    icontact Member

    Joined:
    May 25, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    I've followed your suggestions:

    resolv.conf seems to be fine.


    Code:
    domain myicontactdns.com
    search myicontactdns.com
    nameserver 65.98.39.89
    nameserver 65.98.39.90
    
    I see alot of this on the exim_mainlog


    /etc/localdomains/ lists the domains hosted on the server.

    I was thinking of rolling back to the stable release but i dont really want to do that right now.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Did you check what the error is saying:
    That is, have you disabled nobody from sending email in WHM > Tweak Settings? If so, and you do not have phpsuexec enabled, then you won't be able to send out email from php scripts.
     
  5. Andrew87

    Andrew87 Member

    Joined:
    May 14, 2005
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I'm not sure if this is a bug or not but I have the same problem.. If you setup your WHM to use 'blackhole' or 'fail', all e-mails which aren't sent to a valid e-mail identity will get bounced back. For some reason the main identity of an account (i.e. the cPanel user login) is for some reason not a proper e-mail account.

    Therefore, if your cPanel login is andrew@domain.com, no e-mails to andrew@domain.com will be received. However, if you were to setup a new account (e.g. bobby@domain.com) all e-mails will successfully be able to reach this account.
     
    #5 Andrew87, Aug 31, 2005
    Last edited: Aug 31, 2005
  6. icontact

    icontact Member

    Joined:
    May 25, 2005
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    This is what I ended up doing in order to fix that problem, it seems that the main username of cPanel is not being recorgnised as an valid email address.

    Anyone been able to find a workaround this?
     
  7. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    For that I'd try:

    /scripts/updateuserdomains
    /scripts/mailperm
     
Loading...

Share This Page