The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can someone help me please with the pop3

Discussion in 'General Discussion' started by aljuhani, Nov 28, 2004.

  1. aljuhani

    aljuhani Member

    Joined:
    Jul 29, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    yesterday I tryed to install mod_dosevasive by following this tutorial
    www (dot) linuxforum (dot) com/linux_tutorials/66/1.php

    and after I finished I went to WHM and installed Mod Security and clamavconnector from Addon Modules

    everything was fine at that time but when I tryed to send an email this morning using Outlook Express it doesn't send any email and I receive the following erorr :

    ====================

    An unknown error has occurred. Subject 'Re: Importent, Account: 'webmaster', Server: 'mail.XXXXXX.net', Protocol: SMTP, Server Response: '451 Temporary local problem - please try later', Port: 25, Secure(SSL): No, Server Error: 451, Error Number: 0x800CCC6A

    ====================

    also when I send an email from other server or from hotmail to my server it doesn't reach my server although I can send an emails by using the webmail on the server
    but I receive only the root emails and from the emails from the helpDesk on my server

    this is what I done and the problem still there

    - I removed mod_dosevasive but I don't now if I did it correctly
    - I removed mod_dosevasive from httpd.conf also the related files in libexec
    - I unchecked Mod Security and clamavconnector from Addon Modules but they still there
    - /scripts/easyapache
    - /scripts/exime4
    - / scripts/sysup
    - /scripts/updatenow
    - /scripts/upcp --force
    - /scripts/fixeverything
    - Graceful Server Reboot from WHM

    I don't know what to do else can someone please help me

    I'm waiting for any answer because I opend a ticket and no answer form the support for almost 12 hours now
     
  2. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    Look in /var/log/exim_mainlog and /var/log/exim_paniclog to see where the problem lies.
     
  3. aljuhani

    aljuhani Member

    Joined:
    Jul 29, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    thank you casey
    but I know nothing about these log files what I should look for

    /var/log/exim_paniclog shows many lines most of them looks the same

    and when I try to run ( pico /var/log/exim_mainlog ) the SSH failed and when try to restart it via WHM I receive :
    Nov 28 15:09:24 server2 sshd: sshd shutdown failed Nov 28 15:09:25 server2 sshd: succeeded sshd has failed, please contact the sysadmin.

    any ideas
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Ok, first to clear up a few things:

    1. This has nothing to do with POP3 as the subject says. This is an SMTP problem.

    2. mod_dos evasive and mod_security have nothing at all to do with this, they only affect Apache.

    3. So, that leaves the installation of clamavconnector that could have caused your problem, if you definitely changed nothing else to do with Exim.

    Now, you do need to do as casey suggested. That is, run the following command from an SSH window:

    tail -f /var/log/maillog

    Then send yourself an email from your hotmail account. Watch what happens in your exim_mainlog when it arraives, and post the information here.
     
  5. aljuhani

    aljuhani Member

    Joined:
    Jul 29, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    when I sent an email from my hotmail account nothing happen no changes also from Gmail account
    but when I tryed to send an email using Outlook Express to hotmail account this is what appeares

    =======

    Nov 28 21:58:19 server2 cpanelpop[15744]: Login host=213.184.166.205 ip=213.184.166.205 user=webmaster@alnamer.net realuser=webmaster@alnamer.net
    Nov 28 21:58:20 server2 cpanelpop[15744]: Session Closed host=213.184.166.205 ip=213.184.166.205 user=webmaster@alnamer.net realuser=webmaster@alnamer.net totalxfer=199

    =======

    If it is clamavconnector how I can remove it or how I can restore the normal setting of exim although I run /scripts/exim4

    I hope that I find a solution by your help

    Thank you,
     
    #5 aljuhani, Nov 28, 2004
    Last edited: Nov 28, 2004
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    There's a very good reason for that...

    I told you the wrong log file :eek:

    You need to:

    tail -f /var/log/exim_mainlog
     
  7. aljuhani

    aljuhani Member

    Joined:
    Jul 29, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    this is what I see when sending from Gmail account

    =========

    clamd: unable to connect to UNIX socket /var/run/clamav/clamd (No such file or directory)
    2004-11-29 01:01:21 1CYWzo-0003Zj-4f H=(wproxy.gmail.com) [64.233.184.204] F=<faisal.5shost@gmail.com> temporarily rejected after DATA

    =========

    :confused:

    I'm waiting for you
     
    #7 aljuhani, Nov 28, 2004
    Last edited: Nov 28, 2004
  8. casey

    casey Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    2,303
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    If there is trouble, it will find me
    pico /etc/clamav.conf

    Find the section that says

    Change that to

    Then restart exim.

    You should be all set after that.
     
  9. aljuhani

    aljuhani Member

    Joined:
    Jul 29, 2003
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Thank you Thank you Thank you Thank you Thank you :D

    I don't know what to say or how to thank you guys

    it has been fixed looooool :)

    Thank you again and again
     
Loading...

Share This Page