The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

can`t start cPanel ssl service - Solution

Discussion in 'General Discussion' started by brhospedagens, May 30, 2006.

  1. brhospedagens

    brhospedagens Member

    Joined:
    Mar 7, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    - SSH to your server

    - Type: ps aux | grep stunnel (there must be an output with something like this):

    cpanel 29430 0.0 0.1 4600 1672 ? Ss 18:10 0:00 /usr/bin/stunnel-4.15local /usr/local/cpanel/etc/stunnel/default/stunnel.conf.run

    - Copy that only stunnel-4.15local or whatever version is on your box.

    - pico -w /usr/local/cpanel/etc/init/stopstunnel


    #!/usr/bin/perl

    killstunnel();
    sub killstunnel {
    system("/scripts/ckillall -9 stunnel");
    system("/scripts/ckillall -9 stunnel-3.22local");
    system("/scripts/ckillall -9 stunnel-4.00local");
    system("/scripts/ckillall -9 stunnel-4.02local");
    system("/scripts/ckillall -9 stunnel-4.04local");
    system("/scripts/ckillall -9 stunnel-4.05local");
    system("/scripts/ckillall -9 stunnel-4.15local"); <- Create a new line with your stunnel version
    }


    - service cpanel restart


    - Thing should be ok then.

    Regards,
     
  2. alex2k

    alex2k Active Member

    Joined:
    Sep 10, 2001
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    Thank's for howto but I still got blank page when using https :(
     
  3. brhospedagens

    brhospedagens Member

    Joined:
    Mar 7, 2006
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1

    alex: For https you must install an server certificate. Did u do it ?

    Regards,
     
Loading...

Share This Page