keat63

Well-Known Member
Nov 20, 2014
1,916
263
113
cPanel Access Level
Root Administrator
Is there a away to supress these messages ?
They are starting to annoy me a little.

/usr/local/cpanel/logs/error_log:
==> cpsrvd 11.56.0.14 started
==> cpsrvd: loading security policy....Done
==> cpsrvd: Setting up native SSL support ... Done
==> cpsrvd: transferred port bindings
==> cpsrvd: bound to ports

Maybe I should add, that I've since disable 'Dormant Service' on cpsrvd, but i'd rather leave the default switch on and supress the message.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

As you mentioned, this behavior is associated with the dormant service functionality for cpsrvd in version 56. Per our documentation:

This setting configures the system to unload idle services from memory after up to ten minutes of inactivity, and then loads listening devices that correspond to it. This setting reduces memory usage, but delays responses from dormant services. When you enable this setting for a service, that service will immediately enter dormant mode whenever you reboot your server or restart the service.

Thus, this is why you see log output like this in /usr/local/cpanel/logs/error_log whenever the service exits out of dormant mode:

Code:
==> cpsrvd 11.56.0.8 started
==> cpsrvd: loading security policy....Done
==> cpsrvd: Setting up native SSL support ... Done
==> cpsrvd: transferred port bindings
==> cpsrvd: bound to ports
You can read more about this in the version 56 release notes:

56 Release Notes - Documentation - cPanel Documentation

It's not possible to suppress this output. I suggest opening a feature request if you would like to see feedback on this proposal from our development team:

Submit A Feature Request

Thank you.