cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

PEAR is bundled with PHP in EasyApache 4. EX:

Code:
# rpm -qa|grep pear
ea-php56-pear-1.10.1-7.7.16.cpanel.noarch
ea-php70-pear-1.10.1-7.7.19.cpanel.noarch
ea-php55-pear-1.10.1-7.7.16.cpanel.noarch
Is there anything in-particular about the existing versions that is leading to the request for a newer version?

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,218
463
Hello,

PEAR 1.10.1 (with additional cPanel patches) is included with EasyApache 4 for each PHP version. EX:

Code:
# rpm -qa|grep pear
ea-php70-pear-1.10.1-7.7.24.cpanel.noarch
ea-php55-pear-1.10.1-7.7.20.cpanel.noarch
ea-php56-pear-1.10.1-7.7.21.cpanel.noarch

# rpm -q --changelog ea-php56-pear-1.10.1-7.7.21.cpanel.noarch
* Thu Mar 23 2017 - 1.10.1-7
- PIG-2903: Enable PECL extensions by default

* Fri Dec 16 2016 - 1.10.1-6
- EA-5493: Added vendor field

* Tue Aug 02 2016 - 1.10.1-5
- EA-4954: Add support for php71 (beta)

* Mon Jun 20 2016  - 1.10.1-4
- EA-4383: Update Release value to OBS-proof versioning

* Wed Jun 15 2016 - 1.10.1-cp3
- Set 'download_dir' to a SCL path instead of using /tmp

* Tue May 31 2016 -  1.10.1-cp2
- Create a symlink to the 'pear' script at /usr/local/bin/pear

* Mon May 16 2016 - 1.10.1-cp1
- Initial implementation of PEAR/PECL for EA4 SCL-PHP package
It seems more likely that it's a specific PEAR module the customer's script may require. Could you check and verify if that's the case?

Thank you.