The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot access Cpanel or WHM

Discussion in 'General Discussion' started by jamesalexhall, Apr 26, 2012.

  1. jamesalexhall

    jamesalexhall Registered

    Joined:
    Apr 26, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Hello,

    I cannot access Cpanel and WHM. Eveything was working fine about a week ago. I tried to log in to cpanel yesterday but got a blank screen. I rebooted my server remotely but now just get an error message (below). My hosting company "Memset" say they think is is due to a failed upgrade. The pointed me at this thread:
    http://forums.cpanel.net/f5/problem-new-version-268681.html

    I have tried to follow the steps but there is no line with "default_login_theme=cpanel-legacy" in the cpanel.config file so I dont think this is the issue.

    Cpanel is running on Cent OS. This is the error:

    Code:
    --------
    
    Internal Server Error
    
    Can't locate Cpanel/LegacyLogin.pm in @INC (@INC contains: /usr/local/cpanel /usr/local/cpanel /usr/local/cpanel/perl/_diet /usr/local/cpanel/Cpanel/CPAN/overload/__Time /usr/local/cpanel/Cpanel/CPAN/overload/__File__GlobMapper /usr/local/cpanel/Cpanel/CPAN/overload/__Digest /usr/local/cpanel/perl /usr/local/cpanel /usr/local/cpanel/build-tools/stubs /usr/local/cpanel/perl/C220 /usr/local/cpanel/perl/5.6.2/i686-linux /usr/local/cpanel/perl/5.6.2/i686-linux /usr/local/cpanel/perl/5.6.2 /usr/local/cpanel/perl/site_perl/5.6.2/i686-linux /usr/local/cpanel/perl/site_perl/5.6.2/i686-linux /usr/local/cpanel/perl/site_perl/5.6.2 /usr/local/cpanel/perl/site_perl/5.6.2/i686-linux /usr/local/cpanel/perl/site_perl/5.6.2 /usr/local/cpanel/perl/site_perl . /usr/local/cpanel/perl/5.6.2/i686-linux /usr/local/cpanel/perl/5.6.2 /usr/local/cpanel/perl/site_perl/5.6.2/i686-linux /usr/local/cpanel/perl/site_perl/5.6.2 /usr/local/cpanel/perl/site_perl .) at (eval 7) line 1.
    
     at (eval 7) line 1
    	eval 'require Cpanel::LegacyLogin;' called at cpsrvd-ssl line 8115
    	main::process_legacy_login('login', 'IO::Socket::SSL=GLOB(0x88a5614)', 'cpanel', 'goto_uri', '/', 'dest_uri', '/', 'user', ...) called at cpsrvd-ssl line 2635
    	main::badpass() called at cpsrvd-ssl line 4716
    	main::handle_auth() called at cpsrvd-ssl line 993
    	main::handle_one_connection() called at cpsrvd-ssl line 863
    
    --------
    /https://hallyaa1.miniserver.com:2083/

    Any help much appreciated. Let me know if you need any further info.

    Thanks, James.
     
  2. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Please open a ticket using the link in my signature.
     
  3. minosjl

    minosjl Well-Known Member

    Joined:
    Jun 4, 2011
    Messages:
    168
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    India
    cPanel Access Level:
    Root Administrator
    Hi,

    Did you tried /scripts/upcp --force on your server ?
     
  4. NetMantis

    NetMantis BANNED

    Joined:
    Apr 22, 2012
    Messages:
    117
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Utah
    cPanel Access Level:
    DataCenter Provider
    Try connecting without SSL on port 2082 (or 2086 for WHM)

    Blank page sounds more like your SSL has gotten messed up or removed.

    A self signed certificate is fine but if that's not working and you either go to SSL addresses or setup "Tweak Settings" to force and SSL connection when it's not working will leave you with a blank page.

    If your server is configured to force an SSL connection, you can manual change the setting in the main cpanel config file located in /var/cpanel and turn off the forced SSL redirects.

    Aside from SSL problems mentioned above, it is possible that your internet connection is being blocked from reaching the normal Cpanel and WHM ports. Universities and hospitals are notoriously bad about doing that as are many workplace employers out there. Some ISPs block all ports but that is not as common. If you are going through a proxy server to reach your server, that too may have the ports that you need blocked from access.

    Try to work with the SSL issue first as I think that may be your main primary problem here.
     
  5. Oleg.Gricik

    Oleg.Gricik Well-Known Member

    Joined:
    Nov 2, 2011
    Messages:
    62
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    First of all you need to fix these things. I suppose some of perl modules are messed.
    In this case check the following article:
    Fixing a Suddenly “Broken” cPanel Installation :: The cPanel Admin
     
Loading...

Share This Page