The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot access cPanel/WHM after reboot

Discussion in 'General Discussion' started by zohair28, Apr 13, 2012.

  1. zohair28

    zohair28 Member

    Joined:
    Jan 26, 2010
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Hi All,

    During fixing /home file permissions. The /etc file permission changed and now SSHD is down. cPanel/WHM is working fine but I can not access server via SSH. I tried to reinstall SSH via cPanel/WHM RPM manager but I can not.

    Is there any solution via WHM to restore /etc file permission for SSH. I tried to restart SSH and update cPanel via WHM but it is still down.

    Any ideas how o solve this ???


    Regards
     
  2. thewebhosting

    thewebhosting Well-Known Member

    Joined:
    May 9, 2008
    Messages:
    1,201
    Likes Received:
    1
    Trophy Points:
    38
    Re: SSHD down and I can not access server/ cPanel/WHM is working

    I do not think so if there is anyway you can restore permissions of /etc folder from WHM. Regarding SSH not working issue, please make sure that the port you have set up for SSH is indeed open in your server firewall.
     
  3. asadhaider

    asadhaider Registered

    Joined:
    Jan 14, 2012
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: SSHD down and I can not access server/ cPanel/WHM is working

    Try this:
    Code:
    http://yourdomain.com:2086/scripts2/doautofixer?autofix=safesshrestart
     
  4. NixTree

    NixTree Well-Known Member

    Joined:
    Aug 19, 2010
    Messages:
    387
    Likes Received:
    1
    Trophy Points:
    18
    Location:
    Gods Own Country
    cPanel Access Level:
    Root Administrator
    Re: SSHD down and I can not access server/ cPanel/WHM is working

    Hello,

    Are you aware what permissions are changed exactly? If so the better solution is to connect to the server via console and fix them!

    Thank you,
    Nibin.
     
  5. JayFromEpic

    JayFromEpic Well-Known Member

    Joined:
    Apr 2, 2011
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Scottsdale, AZ
    cPanel Access Level:
    Root Administrator
  6. mrishadali

    mrishadali Registered

    Joined:
    Apr 23, 2012
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Re: SSHD down and I can not access server/ cPanel/WHM is working

    Hi all,
    I am a newbie with server management.
    I did a graceful reboot yesterday. I can access it via SSH but cPanel and WHM not working.
    Any help is appreciated.
    Thanks
     
  7. ruzbehraja

    ruzbehraja Well-Known Member

    Joined:
    May 19, 2011
    Messages:
    383
    Likes Received:
    7
    Trophy Points:
    18
    cPanel Access Level:
    Root Administrator
    Re: SSHD down and I can not access server/ cPanel/WHM is working

    Your problem is unrelated to the topic of this thread.

    What do you see when you type in http://hostname.com/cpanel or /whm?

    Can you access using the ports: hostname.com:2082 / 2086
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you are running a firewall, take down the firewall or flush it to check if you can then access cPanel and WHM:

    Code:
    /sbin/iptables -F
    You can see if you are running CSF or APF with the following:

    Code:
    whereis csf
    whereis apf
    If you have either, disable that firewall. Oftentimes, a reboot will knock out any rules you had for allowing the cPanel and WHM ports if whoever added the rules for the ports didn't actually save the changes with service iptables save.

    If you are able to then access, please add these rules to the firewall after restarting iptables again to reload the rules:

    Code:
    service iptables restart
    /sbin/iptables -I INPUT -p tcp -m tcp --dport 2082:2083 -j ACCEPT
    /sbin/iptables -I INPUT -p tcp -m tcp --dport 2086:2087 -j ACCEPT
    /sbin/iptables -I INPUT -p tcp -m tcp --dport 2095:2096 -j ACCEPT
    Now, ensure the new rules save this time:

    Code:
    service iptables save
     
Loading...

Share This Page