Cannot access feature list file - CloudFlare::zone_get_stats: Bad file descriptor

postcd

Well-Known Member
Oct 22, 2010
721
21
68
I found these in cPanel error_log:


One part:

Code:
014-11-05 05:22:47 -0500] warn [cpanel] Cannot access feature list file: /var/cpanel/features/myusername_default: No such file or directory at /usr/local/cpanel/Cpanel/Features/Cpanel.pm line 66
	Cpanel::Features::Cpanel::calculate_cache_file_name_and_maxmtime('ilforum', ARRAY(0x7fbbe537ef90)) called at /usr/local/cpanel/Cpanel.pm line 330
	Cpanel::_load_featurelists(HASH(0x7fbbe5377800), 1415182967) called at /usr/local/cpanel/Cpanel.pm line 143
	Cpanel::initcp(Cpanel=HASH(0x7fbbe53777b0)) called at cpanel line 645

Second part:

Code:
[2014-11-05 05:22:52 -0500] info [cpanel] zone_get_stats
[2014-11-05 05:22:53 -0500] warn [cpanel] Unable to run [Cpanel::CloudFlare::api2_get_stats(homedir /home/ilforum user_api_key fafaee9a1caebbf81e60eb6e56d2875ccfb14 cache_fix 1415189939937 zone_name mydomain.com user_email [email][email protected][/email])]: Bad file descriptor (malformed JSON string, neither array, object, number, string or atom, at character offset 1 (before "(end of string)") at /usr/local/cpanel/Cpanel/JSON.pm line 56.
) at /usr/local/cpanel/Cpanel/Api2/Exec.pm line 129
	Cpanel::Api2::Exec::api2_exec('CloudFlare', 'zone_get_stats', HASH(0x7fc7320f9a20), HASH(0x3af5e40)) called at cpanel line 1371
	main::docpanelaction(HASH(0x3af5eb0)) called at cpanel line 5066
	main::run_fast_json_mode() called at cpanel line 775
[2014-11-05 05:22:53 -0500] warn [CloudFlare::zone_get_stats] Encountered error in CloudFlare::zone_get_stats: Bad file descriptor

The second one is probably result of me trying to click "Statistics and Settings" on Cloudflare Account page in cPanel. It always return "AJAX Error: Please refresh the page and try again."
 

postcd

Well-Known Member
Oct 22, 2010
721
21
68
Cloudflare now works, i tried this command "/usr/local/cpanel/bin/cloudflare_update.sh"
First error NOT SOLVED yet.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
Hello :)

Check to see if the following file exists on your system:

/var/cpanel/features/myusername_default

Thank you.
 

postcd

Well-Known Member
Oct 22, 2010
721
21
68
Hello, that file does not exist.
In WHM, Feature manager, i see there is feature list "default" and it "opens" in WHM.
So i created new feature list myusernamehere_default and opened a cPanel account from WHM, so far cant see any errors in cP error log.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,243
463
So i created new feature list myusernamehere_default and opened a cPanel account from WHM, so far cant see any errors in cP error log.
Hello,

I'm happy to see it's now working well. Let us know if you encounter additional issues with the feature list.

Thank you.