Cannot backup user's data

urello

Member
Mar 3, 2015
13
0
1
cPanel Access Level
Root Administrator
When i try to backup user's data, i get the following error
One or more files in the home directory were not readable and were not copied. Please review the home directory upon completion of transfer

WARN: Warnings(s) encountered in tar during archiving:
b_find(): /home3/cpuser675: Permission denied
Backup file is created, but majority of files and dirs are missing.

I run pkgacct under root.
I tried to run both pkgacct cpuser675 and pkgacct cpuser675 userbackup.
I tried to remount /home3 filesystem.
I tried to compress/uncompress manually - tar -cf test.tar /home3/cpuser675; tar -xf test.tar - no errors, all files and dirs are present.
I did the same with gtar - no errors, all files and dirs are present.
Any suggestions?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello :)

What are the permission/ownership values on the /home3/$username directory of the account you are attempting to package?

Thank you.
 

rclemings

Well-Known Member
Nov 5, 2007
51
5
58
Same problem here with WHM 11.48.0 (build 13):

drwx--x--x 44 cybraria cybraria 4096 Mar 3 19:52 /home/cybraria/

From the cpbackup log

[2015-03-03 02:32:24 -0500] Creating Archive ...................................
...................
[2015-03-03 02:32:29 -0500]
One or more files in the home directory were not readable and were not copied.
Please review the home directory upon completion of transfer

WARN: Warnings(s) encountered in tar during archiving:
b_find(): /home/cybraria: Permission denied

[2015-03-03 02:32:29 -0500]
One or more files in the home directory were not readable and were not copied.
Please review the home directory upon completion of transfer
[2015-03-03 02:32:29 -0500] Done
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello :)

Internal case number 169621 is open to track reports of this issue. I suggest opening a support ticket using the link in my signature so we can reproduce this issue and add additional information to the case we have open.

Thank you.
 

rclemings

Well-Known Member
Nov 5, 2007
51
5
58
Tried but failed: "The provided IP (xxx.xx.xxx.xxx) and support access id do not match."

(IP address and support access ID were both copied directly from WHM.)

Hello :)

Internal case number 169621 is open to track reports of this issue. I suggest opening a support ticket using the link in my signature so we can reproduce this issue and add additional information to the case we have open.

Thank you.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Could you try again now? If the issue persists, you can email cs[@]cpanel.net directly and ask that they transfer your request over to our technical support team.

Thank you.
 

rclemings

Well-Known Member
Nov 5, 2007
51
5
58
Could you try again now? If the issue persists, you can email cs[@]cpanel.net directly and ask that they transfer your request over to our technical support team.

Thank you.
done: Support Request Id 6191895 - Incomplete cpanel backups
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
done: Support Request Id 6191895 - Incomplete cpanel backups
It looks like you closed the support ticket before providing authentication details. Feel free to open the ticket again if you want us to proceed.

Thank you.
 

nospa

Well-Known Member
Apr 23, 2012
110
0
66
cPanel Access Level
Reseller Owner
When i try to backup user's data, i get the following error

Backup file is created, but majority of files and dirs are missing.

I run pkgacct under root.
I tried to run both pkgacct cpuser675 and pkgacct cpuser675 userbackup.
I tried to remount /home3 filesystem.
I tried to compress/uncompress manually - tar -cf test.tar /home3/cpuser675; tar -xf test.tar - no errors, all files and dirs are present.
I did the same with gtar - no errors, all files and dirs are present.
Any suggestions?
Hi

Have you found a solution for this? I recently noticed that in 11.46 I have also one account with this problem.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Have you found a solution for this? I recently noticed that in 11.46 I have also one account with this problem.
Hello :)

cPanel & WHM 11.46 is set to reach End of Life at the end of October 2015:

http://news.cpanel.com/11-46-to-eol-in-2-months/

Could you update to a newer version of cPanel and let us know if the issue persists? I'd suggest using cPanel version 11.50 if possible.

Thank you.