The Community Forums

Interact with an entire community of cPanel & WHM users.
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot build Apache

Discussion in 'EasyApache' started by Higgins, Dec 22, 2004.

  1. Higgins

    Higgins Well-Known Member

    Joined:
    Jan 31, 2003
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    6
    I upgrade today all our Servers to the newest Apache + PHP. Except one Server i cant compile Apache:

    Building Apache Config.....Done
    Downloading and compiling apache+modules....


    Verifying archive integrity... All good.
    Uncompressing buildapache.......................................................................................................................
    Verifying compiler and libs....Updating /scripts...Done
    Verifying installation....Using RPM Backend: RPM version 4.2.1
    Using RPM Backend: RPM version 4.2.1
    Done
    Done
    ********************************
    This is buildapache version 9.9.8s
    ********************************
    buildapache configured from Web Host Manager
    Apache configured from Web Host Manager!
    Untarring expat...Unable to fetch expat-1.95.6.tar.gz
    Attempting to restart httpd
    Waiting for httpd to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.

    Server is Fedora Core1 and i have no Idea why he dont want to fetch expat and compile Apache. Any ideas ?
     
  2. firexit

    firexit Active Member

    Joined:
    Nov 4, 2004
    Messages:
    29
    Likes Received:
    1
    Trophy Points:
    8
    i have the same prob

    i have a vserver with the same problem.
    tring to update the php and the apache and i had the cpanel tuned to EDGE and for some resone it takes 4.3.9 php versio insted of 4.3.10 and doesnt reconpile it very well

    that is the output i get :

    Building Apache Config.....Done
    Downloading and compiling apache+modules....


    Attempting to restart httpd
    Waiting for httpd to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.


    httpd status root 11447 4.1 0.2 17008 10384 ? SN 04:03 0:00 /usr/local/apache/bin/httpd -DSSL



    httpd started ok
    Build Complete
     
  3. paradoxic

    paradoxic Member
    PartnerNOC

    Joined:
    Jun 13, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    I cannot recompile with 4.10, it complains about a mod_rewrite directive with an incorrect variable. This is pretty dissapointing, as the security issues in 4.9 php are pretty serious.
     
  4. Higgins

    Higgins Well-Known Member

    Joined:
    Jan 31, 2003
    Messages:
    82
    Likes Received:
    0
    Trophy Points:
    6
    Solved it today with a little workaround.

    When i tried to to install the installer received a "Memory Access Error" from wget and stopped the install Process. So i had manually Downloaded all Packages started buildapache from WHM and copied all packages to the cpapachebuild directory so the Installer did not need to Download anything. Then Buildapache worked without a Problem and compiled everything.

    So i have to find out why i get a Memory Access Error.
     
Loading...

Share This Page