Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Cannot cd to dir /var/spool/exim_incoming/input/

Discussion in 'General Discussion' started by azweb, Nov 19, 2004.

  1. azweb

    azweb Member

    Joined:
    Jan 24, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    Hi, I had problems with email not able to send or receive. I read the solutions here and once I added "Incoming Queue Dir = /var/spool/exim_incoming/input/*", the email was up and running. But when I use "tail -f /var/log/maillog" I get "Cannot cd to dir /var/spool/exim_incoming/input/"

    Can anyone tell me how to fix this or is this not even a problem since my email seems to be working fine and is catching SPAM coming in. Thanks.
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    If you have the following set in /etc/exim.conf:

    split_spool_directory = yes

    Then you need to make that change as you have in MailScanner.conf, plus:

    1. Did you set the following directive for MailScanner too:

    Split Exim Spool = yes

    2. Did you restart MailScanner, this should do it:

    killall -HUP MailScanner

    3. Did you precreate the directories 0-9 a-z A-Z in /var/spool/exim_incoming/input/

    If you have manually set the split_spool_directory = no in exim.conf, then you should not do any of the changes above or add the /* to the Incoming Queue Dir.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. azweb

    azweb Member

    Joined:
    Jan 24, 2004
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    151
    Hi. I did everything except "precreate the directories 0-9 a-z A-Z", wasn't sure how to do that.
    But I decided to set split_spool_directory = no in exim.conf and when I "tail -f /var/log/maillog" I get the following so everything seems to be working fine now.

    "Nov 19 10:11:15 Server cpanelpop[19785]: Session Closed host=xxxx.xxx ip=xx.xx.xx. user=xx@xxx.com realuser=xx@axxx.com totalxfer=188"

    Is there an advantage to use split_spool_directory from "no" to "yes"?

    Thanks for your help.
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,470
    Likes Received:
    21
    Trophy Points:
    463
    Location:
    Go on, have a guess
    Only if your server has a heavy email load (for example, a lot of large active mailing lists), otherwise you're not missing anything by setting it to "no".
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice