The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot change Apache Config or use EasyApache through WHM

Discussion in 'EasyApache' started by augiem, Jan 28, 2014.

  1. augiem

    augiem Member

    Joined:
    Mar 27, 2011
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    WHM 11.40.1

    I am unable to make changes to the Apache Global Configuration or get to EasyApache Exhaustive Options page. In both these cases, the page times out every single time in multiple browsers. In the case of Apache Global Config, I can load the page, but as soon as I try to save it, it fails. In the case of EasyApache, I can step through the profile pages until I get to the Exhaustive Options page, at which point it waits about 30 seconds then fails to load. The server is a VPS at Knownhost with 2GB memory. At the time I tried these, I did a reboot and had 1.8GB of memory free. WHM was force updated by support because of some recurring vhost configuration issue and since then I cannot access these two pages (probably more but these are all I tried.) When I run /scripts/rebuildhttpdconf from the SSH it works fine. Apache is also up and running fine as well. Something broke WHM's ability to update the config file as well as the ability to serve the options page for easy apache. Knownhost's support keeps ignoring my questions and giving me useless information telling me I don't have enough memory free.
     
  2. HostingH

    HostingH Well-Known Member

    Joined:
    Jan 13, 2008
    Messages:
    73
    Likes Received:
    3
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Hello,

    As per the explanation, there must be a problem with your VPS configuration. Like allocated resources and currently used resources.
    If you can find it, your issue will be resolved.

    Thanks,
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Check to see if you notice any fail counts for your VPS resource parameters in the following file (assuming it's an OpenVZ/Virtuozzo platform):

    Code:
    /proc/user_beancounters
    Also, review the cPanel error log (/usr/local/cpanel/logs/error_log) when you encounter this issue to see if there is any output.

    Thank you.
     
Loading...

Share This Page