The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cannot configure Mail (MacOs) to use my SMTP server

Discussion in 'E-mail Discussions' started by trucmuche, Apr 15, 2016.

  1. trucmuche

    trucmuche Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    61
    Likes Received:
    2
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Hello,

    I have a strange problem. I created an email account using CPanel. I setup manually outlook using the parameters given by CPanel : all is fine. I can receive and send emails using this account. But when I use the parameters to configure Apple's Mail application (Mavericks), I can't connect to SMTP server (using SSL or not).

    I tried to stop my firewall, nothing helps. I'm using Gmail's SMTP servers to send email without any problem, but impossible to use my CPanel' configured SMTP server.

    Mail does not give me explicit error messages. It gives me (in french so I translate for you) : "Cannot connect to this SMTP server. Check your internet connexion and the informations written in the account configuration".

    How can I get more informations about this problem ? I don't know exactly where to look for understanding the problem and (I hope) getting a solution...

    Many thanks for your help,

    T.
     
  2. bouerenick

    bouerenick Registered

    Joined:
    Apr 16, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    bouere
    cPanel Access Level:
    Website Owner

    Hi, I'm also in France and since all my accounts have been moved to a new server, I can't send email either ... keep getting TCP/IP Error - 3158
     
  3. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,787
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Try using "telnet" from your workstation to connect to the cPanel server over the SMTP port you have configured (e.g. 25, 587). EX:

    Code:
    telnet your-server.tld 25
    Also, try enabling an alternate port for Exim via the "Exim Mail Server (on another port)" option in "WHM >> Service Manager". Then, allow that port in your server's firewall, and use that port in your email client when configuring your SMTP settings.

    Thank you.
     
  4. trucmuche

    trucmuche Well-Known Member

    Joined:
    Nov 20, 2014
    Messages:
    61
    Likes Received:
    2
    Trophy Points:
    8
    cPanel Access Level:
    Root Administrator
    Thank you for your answer. When I test the port 25 using telnet, here is what I get :
    Code:
    localhost:~ user$ telnet myserver.com 25
    Trying 5.xxx.yyy.zzz...
    telnet: connect to address 5.xxx.yyy.zzz: Connection refused
    telnet: Unable to connect to remote host
    ^C
    My computer's firewall is disabled. When I test the port 465, I get :
    Code:
    Connected to myserver.com.
    Escape character is '^]'.
    I'm installing SSL certificates to see if I can connect using SSL... But what's wrong with SMTP on port 25 ?
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,787
    Likes Received:
    665
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's possible that your ISP or your data center is restricting access to port 25. Try enabling another port for Exim per the instructions in my previous response to see if that addresses the issue, or contact your ISP and data center to see if they are blocking access to that port (It's a common practice).

    Thank you.
     
  6. kduvall

    kduvall Member

    Joined:
    Nov 24, 2008
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Atlanta, GA
    Also of note .. it's common practice for VPN providers that don't maintain logs to disable SMTP to prevent rampant outgoing SPAM. For my current VPN provider, as long as your mail server is not an open relay, you can request for them to enable SMTP for a server.
     
Loading...

Share This Page