SpaceCowboy

Well-Known Member
Jan 18, 2014
54
5
8
cPanel Access Level
Website Owner
Can someone lend me a hand with this?
I'm trying to enable php function exec()
It is not disabled by php.ini

So why doesn't it work? What else can i try? it's CentOS btw.

Thanks.
 

SysSachin

Well-Known Member
Aug 23, 2015
604
49
28
India
cPanel Access Level
Root Administrator
Twitter
Hello,

Please make sure which php.ini file is using your account. For that you can create phpinfo file and check the your account php.ini configuration file path.
 

SpaceCowboy

Well-Known Member
Jan 18, 2014
54
5
8
cPanel Access Level
Website Owner
Hello,

Please make sure which php.ini file is using your account. For that you can create phpinfo file and check the your account php.ini configuration file path.
Hi ok i did, it says:
Code:
Loaded Configuration File    /opt/cpanel/ea-php56/root/etc/php.ini
The line disabled functions is empty:
Code:
disable_functions =
But the PHP info page says:
Code:
disable_functions    exec,passthru,shell_exec,system
Where is it getting it from? Not from php.ini so where is it?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,884
2,254
463
Hello,

Could you verify if you used "WHM Home >> Software >> MultiPHP INI Editor" to make the change to the 'disable_functions' line? If not, could you browse to Editor Mode on this option and save the changes?

Note that on systems that run EasyApache 4, multiple php.ini and local.ini files manage your system's PHP. Each version of PHP on your systems uses its own php.ini and local.ini file. You must make changes to each file separately. Please also see this document:

The cPanel PHPRC PHP Patch for EasyApache 4 - EasyApache 4 - cPanel Documentation

Thank you.