The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot Find IP Tables

Discussion in 'General Discussion' started by PIBiker, Jun 25, 2005.

  1. PIBiker

    PIBiker Registered

    Joined:
    Jun 23, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Philippines
    I have tried to install APF today and when I start the service I get the error:

    Unable to load iptables module (ip_tables), aborting.

    After this I tried KISS and received:

    Since the ip_tables, ipt_state, and/or ipt_multiport modules do not exist, KISS can not function. Firewall script aborted!

    Anybody know where these tables are and why neither program can find them?
     
  2. Ali Hamad

    Ali Hamad Member

    Joined:
    May 22, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    1
    Hi PIBiker ,

    APF firwall and KISS depend on Iptables .

    heck if Iptables already installed :
    rpm -qa | grep iptables

    or install it :
    yum install iptables
     
  3. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    I have the same problem, but the iptables is installed and runnig:

    root@ssl [/etc/apf]# rpm -qa | grep iptables
    iptables-1.3.0-2

    I execute:

    root@ssl [/etc/apf]# yum install iptables
    Repository updates is listed more than once in the configuration
    Repository base is listed more than once in the configuration
    Setting up Install Process
    Setting up repositories
    Reading repository metadata in from local files
    Excluding Packages in global exclude list
    Finished
    Parsing package install arguments
    Nothing to do

    but:

    root@ssl [/etc/apf]# apf -r
    Unable to load iptables module (ipt_state), aborting.

    ?
     
  4. duranduran

    duranduran Well-Known Member

    Joined:
    Apr 30, 2004
    Messages:
    198
    Likes Received:
    0
    Trophy Points:
    16
    No, it is a dedicated server.
     
  5. mctDarren

    mctDarren Well-Known Member

    Joined:
    Jan 6, 2004
    Messages:
    664
    Likes Received:
    2
    Trophy Points:
    18
    Location:
    New Jersey
    cPanel Access Level:
    Root Administrator
    Either of these issues on a VPS?
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Probably means you have a monolithic kernel (i.e. no LKMs) there's a setting in APF to skip module loading in that case. You'd have to hack around with KISS to get it to load by commenting out the module loads.

    Installing the iptables rpm is not relevant. iptables has to be either compiled into the kernel or built as LKM modules. The rpm simply contains the command line utils which aren't the problem here.
     
  7. WiroWaas

    WiroWaas Member

    Joined:
    Aug 11, 2006
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    How to hack it?
     
  8. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Same here

    Starting APF:Unable to load iptables module (ipt_state), aborting.

    How do I fix this?
     
  9. jayh38

    jayh38 Well-Known Member

    Joined:
    Mar 3, 2006
    Messages:
    1,215
    Likes Received:
    0
    Trophy Points:
    36
    Are you on a VPS? if so you need to comply with Chirpy's post above.
     
  10. AndyReed

    AndyReed Well-Known Member
    PartnerNOC

    Joined:
    May 29, 2004
    Messages:
    2,222
    Likes Received:
    3
    Trophy Points:
    38
    Location:
    Minneapolis, MN
    Just enable the no kernel option in /etc/apf/conf.apf
    It should be like this:
    SET_MONOKERN="1"
    Save and then restart apf: /usr/sbin/local/apf -r
     
Loading...

Share This Page