The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

cannot get email filtering to work

Discussion in 'E-mail Discussions' started by Tipiford, Aug 13, 2015.

  1. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Under Account Level Filtering, I am trying to use the "ends with" filtering rule with "@domain.com" to "Fail With Message" and "Discard Message," neither of which is working for me. After setting the rules and saving, I get the message, "You have successfully created a new filter," but testing by sending an email from that domain, neither bounces nor discards the email. Am I missing a rule here?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  3. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
     
  4. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Untitled-2.jpg
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You should not configure both a "Fail with Message" and a "Discard Message" action in the same rule. There's no need to discard a message if it's already bounced to the user. Also, try using "Any Header" and "Contains" to see if that helps block the mail.

    Thank you.
     
  6. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
     
  7. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thanx, I used the "Contains" option, which bounced and discarded the message. What was confusing was the option to add as many rules as you might want, so, if two or more rules are a no-no, then that should not be allowed by the system. Anyway, it's working, and Thanx.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  9. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Guess I spoke a little too soon. The "contains" option seemed to work on one address, but did not work on another. I have tried both "contains" and "ends with" options, and both fail on certain addresses. (And I don't have the "any header" option you mentioned.) The "equals" option cannot work with many bulk mailers, as they change the first part of their address with something like, "bounce-md_30000838.55d0e63c.v1-c2e199fbcbee1ab0ccdbde4ec3@" or some such. Seems like cPanel would program this to include wildcards.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It's in the first drop-down box under rules. What options do you see?

    Thank you.
     
  11. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
  13. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Thanx, I'll test that out over the next few days and report back (Success)!
     
  14. Tipiford

    Tipiford Member

    Joined:
    Feb 5, 2014
    Messages:
    23
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Website Owner
    Yep, there's joy in Mudville. "Any Header" and "contains" is working fine. Issue resolved.

    Thanx for the assist.
     
  15. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,678
    Likes Received:
    648
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I am happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
Loading...

Share This Page