The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot get Exim's Advanced Editor to Accept Changes

Discussion in 'E-mail Discussions' started by leptserkhan, Dec 14, 2011.

  1. leptserkhan

    leptserkhan Registered

    Joined:
    Dec 14, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Reseller Owner
    Hello.

    I am using WHM 11.30.5 build 2.

    Inside Exims Configuration Editor it states:

    "To use simply add new directives or modify current directives within the provided text boxes. Any options added to the first textbox will override the options provided in the default configuration. All other textboxes will not override their respective sections.
    "

    Now here's the confusion: there are several blank boxes in the Advanced Configuration Editor presumably to input changes -- one at the top which I understand will override the default configuration, and others that will not. However, whenever I attempt to, say, input the following changes into any of those boxes I am receiving the error listed below and the changes are not being saved. Yet there is no visible means to delete the existing entries. How does one go about deleting entries in order to overwrite with new entries?

    I want to input this:

    remote_smtp: driver = smtp interface = ${lookup{$sender_address_domain}lsearch{/etc/domainips_reverse}{$value}{$interface_address}} helo_data = ${lookup{$interface_address}lsearch{/etc/domainips}{$value}{$primary_hostname}}Yet I'm receiving this error message whenever attempting to do so:


    Error message from syntax check: 2011-12-14 20:44:59 Exim configuration error in line 8 of /etc/exim.conf.buildtest.work.3vL06FqPHomMc4j_: main option "remote_smtp" unknown

    The following does indeed exist in the existing configuration, yet as stated above, there is no obvious
    method to delete entries:

    remote_smtp: driver = smtp interface = ${if exists {/etc/mailips}{${lookup{$sender_address_domain}lsearch*{/etc/mailips}{$value}{}}}{}} helo_data = ${if exists {/etc/mailhelo}{${lookup{$sender_address_domain}lsearch*{/etc/mailhelo}{$value}{$primary_hostn ame}}}{$primary_hostname}}
     
  2. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    The remote_smtp driver is listed in the "transports" section of /etc/exim.conf file and is not editable. Placing an existing transport at the top or any other field will result either in the message you received, or result in this message if you put it into the transports section where it belongs:

    Code:
    Error message from syntax check:
    2011-12-18 14:05:50 Exim configuration error:
      there are two transports called "remote_smtp"
    Of note, here is what I tried to place into that field for the transports section with the proper line returns:

    Code:
    remote_smtp: 
    driver = smtp 
    interface = ${lookup{$sender_address_domain}lsearch{/etc/domainips_reverse}{$value}{$interface_address}}
    helo_data = ${lookup{$interface_address}lsearch{/etc/domainips}{$value}{$primary_hostname}}
    Here is a discussion on the only current method available for editing the remote_smtp transport area in cPanel:

    http://forums.cpanel.net/f43/scripts-posteximup-help-205971.html#post845302

    Basically, you'd replace our /etc/exim.conf file with your revised copy, place a copy of your revisions in /root and then create a /scripts/posteximup file (and I'd also suggest a /scripts/postupcp as well script) to copy that file to re-replace the /etc/exim.conf whenever eximup and upcp are used on the machine.
     
  3. leptserkhan

    leptserkhan Registered

    Joined:
    Dec 14, 2011
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Reseller Owner
    Hi Tristan and thank you for responding. That indeed has cleared up my confusion and I appreciate the information. Here is my continuing dilemma in regards to Cpanel and Exim - I have several VPSs on a hosting account, let's call them mainserver.com with IP address as 123.456.789.123 and mainserver2.com as 123.456.789.125.

    As per instructions in the Cpanel documentation, I have set ON "Reference /etc/mailips for outgoing SMTP connections" and "/etc/mailhelo for outgoing SMTP HELO". Presumably this leads an administrator like myself to believe that doing this would set the domain name "mainserver.com" when 123.456.789.123 is connecting for outgoing mail as well as "mainserver2.com" as domain name when "123.456.789.125" is connecting for outgoing mail; as well, the helo would match this pattern. Indeed this is happening however, my logs and the headers of mail received from, for example mainserver2.com are showing the ip addresses for mainserver.com and not the sending smpt server for mainserver2.com. I have included a snippet of my exim logs below. My goal is to have the headers for outgoing mail from mainserver2 reflect the IP address of that server and not that of mainserver. Toggling the setting "Send mail from account’s dedicated IP" in WHM has no effect whatsoever.

    2011-12-18 22:12:42 H=mainserver.com ([123.456.789.123]) [123.456.789.125] Warning: Sender rate 10.9 / 1h
    2011-12-18 22:12:42 1RcTec-0005lm-Mc <= listbounces@mainserver H=mainserver.com ([123.456.789.123]) [216.172.167.98] P=esmtpsa X=TLSv1:AES256-SHA:256 A=dovecot_login:blabla@blablabla.com S=34680 id=2011121942.22180.1410952761.swift@www.mainserver.com T="12 Great Gift Ideas"
    2011-12-18 22:12:43 1RcTec-0005lm-Mc DK: message signed using a=rsa-sha1; q=dns; c=nofws; s=default; d=mainserver2.com; h=To:From:Subject:Date:MIME-Version:Content-Type:Content-Transfer-Encoding:List-Unsubscribe:X-mid:X-Mailer:X-Sender:Message-ID;
    2011-12-18 22:12:43 1RcTec-0005lm-Mc => mrbigguy87UI@gmail.com R=dk_lookuphost T=dk_remote_smtp H=gmail-smtp-in.l.google.com [74.125.47.87] X=TLSv1:RC4-SHA:128
    2011-12-18 22:12:43 1RcTec-0005lm-Mc Completed

    The mail headers which I'm loath to reproduce here because of their length, do not reflect the connection from mainserver2.com and it's ip address, but rather mainserver.com.

    On a VPS setup in Exim, how does one make outgoing mail headers reflect the ip address of the smtp server of the sending domain rather than the main server's ip? I have read several tech notes in the documentation about various methods, but none of them seem to work.

    Any advice gratefully appreciated.
     
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    I would suggest opening up a ticket for this type of issue for us to check into it further. We would need to test on your specific setup to see what is happening, which is beyond what we can do via the forums. You could open up a ticket in WHM > Support Center > Contact cPanel or using the link in my signature. Please post the ticket number here after submitting one. Thanks!
     
Loading...

Share This Page