Cannot get latest version of SSH to install

trackpads

Active Member
Jul 5, 2004
36
0
156
For some reason when I tell CPanel to upgrade the OpenSSH to the latest it only downloads the 3.6 rpm. Any way to make it download the latest?

Thanks again,

-Jason
 

mickalo

Well-Known Member
Apr 16, 2002
782
5
318
N.W. Iowa
Originally posted by mooseontheloose
cpanel does not depend on ssh for much of anything

no :p
what does this error mean when restart sshd:
Code:
Starting sshd:Privilege separation user sshd does not exist
apparently there ARE some conflicts... I got locked out of the server, via ssh shell. I had to reinstall all the openssh RPM's in order to be able to get back into the server!!

Not sure what happened there!! :confused:

Mickalo
 
Last edited:

mickalo

Well-Known Member
Apr 16, 2002
782
5
318
N.W. Iowa
after doing some searches on EV1 forums, there appears to be some correlation between OpenSSH and OpenSSL versions and compatibility issues. There's some good HOW-TO's but they're over a year old now and not sure they'd be accurate now.

Has anybody sucessfully upgraded OpenSSH and OpenSSL on a Cpanel box with RH, currently using OpenSSH_3.1p1 and OpenSSL OpenSSL 0.9.6b

TIA,
Mickalo
 

chirpy

Well-Known Member
Verifed Vendor
Jun 15, 2002
13,437
33
473
Go on, have a guess
Any particular reason that you need to upgrade openSSH? If you're running a support RedHat release the current rpms will have any security fixes back-ported into the version that is installed (for stability reasons).
 

mickalo

Well-Known Member
Apr 16, 2002
782
5
318
N.W. Iowa
good point. was reading alot of security alerts regarding older versions of these, and was concerned, but it has been pointed out Cpanel keeps things patched quiet well.

Thx's
Mickalo
 

trackpads

Active Member
Jul 5, 2004
36
0
156
I wanted to upgrade because I wasn having the "Corrupted MAC on Input" error when using SCP. But after I installed 3.8 it just got worse so I am going to roll back I think.

Thanks,

-Jason